Cross-Site Scripting in @ionic/core
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-79.
Summary
Versions of `@ionic/core` prior to 4.0.3, 4.1.3, 4.2.1 or 4.3.1 are vulnerable to Cross-Site Scripting (XSS). The package uses the unsafe `innerHTML` function without sanitizing input, which may allow attackers to execute arbitrary JavaScript on the victim's browser. This issue affects the components: - `<ion-alert>.message` - `<ion-searchbar>.placeholder` - `<ion-infinite-scroll-content>.loadingText` - `<ion-refresher-content>.pullingText` - `<ion-refresher-content>.refershingText` ## Recommendation - If you are using @ionic/core 4.0.x, upgrade to 4.0.3 or later. - If you are using @ionic/core 4.1.x, upgrade to 4.1.3 or later. - If you are using @ionic/core 4.2.x, upgrade to 4.2.1 or later. - If you are using @ionic/core 4.3.x, upgrade to 4.3.1 or later.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | @ionic/core (npm) | before 4.0.3 | 4.0.3 | Patch available | GHSA-r3xc-47qg-h929 |
| — | @ionic/core (npm) | 4.1.0 to before 4.1.3 | 4.1.3 | Patch available | GHSA-r3xc-47qg-h929 |
| — | @ionic/core (npm) | 4.2.0 to before 4.2.1 | 4.2.1 | Patch available | GHSA-r3xc-47qg-h929 |
| — | @ionic/core (npm) | 4.3.0 to before 4.3.1 | 4.3.1 | Patch available | GHSA-r3xc-47qg-h929 |
- @ionic/core (npm) Vendor— Affected before 4.0.3 Fixed in 4.0.3 Patch available GHSA-r3xc-47qg-h929
- @ionic/core (npm) Vendor— Affected 4.1.0 to before 4.1.3 Fixed in 4.1.3 Patch available GHSA-r3xc-47qg-h929
- @ionic/core (npm) Vendor— Affected 4.2.0 to before 4.2.1 Fixed in 4.2.1 Patch available GHSA-r3xc-47qg-h929
- @ionic/core (npm) Vendor— Affected 4.3.0 to before 4.3.1 Fixed in 4.3.1 Patch available GHSA-r3xc-47qg-h929
Remediation
- Fix · GHSA-r3xc-47qg-h929 @ionic/core (npm) Fixed in 4.0.3 Advisory →
- Fix · GHSA-r3xc-47qg-h929 @ionic/core (npm) Fixed in 4.1.3 Advisory →
- Fix · GHSA-r3xc-47qg-h929 @ionic/core (npm) Fixed in 4.2.1 Advisory →
- Fix · GHSA-r3xc-47qg-h929 @ionic/core (npm) Fixed in 4.3.1 Advisory →
Timeline
- 2026-10-03 Threatist record created from GHSA-r3xc-47qg-h929
References
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences