Read the docs
TI-2020-19704 Aliases GHSA-jxf5-7x3j-8j9m

Malicious Package in load-from-cwd-or-npm

Priority LOW 38CWE-506Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
Code execution
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-506.

Summary

Version 3.0.2 of `load-from-cwd-or-npm` contains malicious code. The malware breaks functionality of the `purescript-installer` package by injecting targeted code. ## Recommendation Upgrade to version 3.0.4 or later. There is no indication of further compromise.

Why it matters now

Fix Fixed load-from-cwd-or-npm (npm): 3.0.4

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—load-from-cwd-or-npm (npm)3.0.2 to before 3.0.43.0.4Patch availableGHSA-jxf5-7x3j-8j9m
  • load-from-cwd-or-npm (npm) Vendor— Affected 3.0.2 to before 3.0.4 Fixed in 3.0.4 Patch available GHSA-jxf5-7x3j-8j9m

Remediation

  • Fix · GHSA-jxf5-7x3j-8j9m load-from-cwd-or-npm (npm) Fixed in 3.0.4 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-jxf5-7x3j-8j9m

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences