Read the docs
TI-2020-19706 Aliases GHSA-x48m-gp6r-gp4v

Malicious Package in rate-map

Priority LOW 38CWE-506Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
Code execution
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-506.

Summary

Version 1.0.3 of `rate-map` contains malicious code. The malware breaks functionality of the `purescript-installer` package by rewriting code of the `dl-tar` dependency. ## Recommendation Upgrade to version 1.0.5 or later. There is no indication of further compromise.

Why it matters now

Fix Fixed rate-map (npm): 1.0.5

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—rate-map (npm)1.0.3 to before 1.0.51.0.5Patch availableGHSA-x48m-gp6r-gp4v
  • rate-map (npm) Vendor— Affected 1.0.3 to before 1.0.5 Fixed in 1.0.5 Patch available GHSA-x48m-gp6r-gp4v

Remediation

  • Fix · GHSA-x48m-gp6r-gp4v rate-map (npm) Fixed in 1.0.5 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-x48m-gp6r-gp4v

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences