Read the docs
TI-2020-19873 Aliases GHSA-f52g-6jhx-586p

Denial of Service in handlebars

Priority LOW 38CWE-400Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
Denial of service
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-400.

Summary

Affected versions of `handlebars` are vulnerable to Denial of Service. The package's parser may be forced into an endless loop while processing specially-crafted templates. This may allow attackers to exhaust system resources leading to Denial of Service. ## Recommendation Upgrade to version 4.4.5 or later.

Why it matters now

Fix Fixed handlebars (npm): 4.4.5

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—handlebars (npm)4.0.0 to before 4.4.54.4.5Patch availableGHSA-f52g-6jhx-586p
  • handlebars (npm) Vendor— Affected 4.0.0 to before 4.4.5 Fixed in 4.4.5 Patch available GHSA-f52g-6jhx-586p

Remediation

  • Fix · GHSA-f52g-6jhx-586p handlebars (npm) Fixed in 4.4.5 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-f52g-6jhx-586p

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences