Arbitrary Code Execution in handlebars
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- —
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from GitHub.
Summary
Versions of `handlebars` prior to 3.0.8 or 4.5.3 are vulnerable to Arbitrary Code Execution. The package's lookup helper fails to properly validate templates, allowing attackers to submit templates that execute arbitrary JavaScript in the system. It is due to an incomplete fix for a [previous issue](https://www.npmjs.com/advisories/1316). This vulnerability can be used to run arbitrary code in a server processing Handlebars templates or on a victim's browser (effectively serving as Cross-Site Scripting). ## Recommendation Upgrade to version 3.0.8, 4.5.3 or later.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | handlebars (npm) | before 3.0.8 | 3.0.8 | Patch available | GHSA-q2c6-c6pm-g3gh |
| — | handlebars (npm) | 4.0.0 to before 4.5.3 | 4.5.3 | Patch available | GHSA-q2c6-c6pm-g3gh |
- handlebars (npm) Vendor— Affected before 3.0.8 Fixed in 3.0.8 Patch available GHSA-q2c6-c6pm-g3gh
- handlebars (npm) Vendor— Affected 4.0.0 to before 4.5.3 Fixed in 4.5.3 Patch available GHSA-q2c6-c6pm-g3gh
Remediation
- Fix · GHSA-q2c6-c6pm-g3gh handlebars (npm) Fixed in 3.0.8 Advisory →
- Fix · GHSA-q2c6-c6pm-g3gh handlebars (npm) Fixed in 4.5.3 Advisory →
Timeline
- 2026-10-03 Threatist record created from GHSA-q2c6-c6pm-g3gh
References
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences