Read the docs
TI-2020-19905 Aliases GHSA-hg79-j56m-fxgv

Cross-Site Scripting in react

Priority LOW 38CWE-79Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
Cross-site scripting
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-79.

Summary

Versions of `react` prior to 0.14.0 are vulnerable to Cross-Site Scripting (XSS). The package's `createElement` function fails to properly validate its input object, allowing attackers to execute arbitrary JavaScript in a victim's browser. ## Recommendation Upgrade to version 0.14.0 or later.

Why it matters now

Fix Fixed react (npm): 0.14.0

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—react (npm)0.0.1 to before 0.14.00.14.0Patch availableGHSA-hg79-j56m-fxgv
  • react (npm) Vendor— Affected 0.0.1 to before 0.14.0 Fixed in 0.14.0 Patch available GHSA-hg79-j56m-fxgv

Remediation

  • Fix · GHSA-hg79-j56m-fxgv react (npm) Fixed in 0.14.0 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-hg79-j56m-fxgv

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences