Remote Code Execution in next
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- —
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from GitHub.
Summary
Versions of `next` prior to 5.1.0 are vulnerable to Remote Code Execution. The `/path:` route fails to properly sanitize input and passes it to a `require()` call. This allows attackers to execute JavaScript code on the server. Note that prior version 0.9.9 package `next` npm package hosted a different utility (0.4.1 being the latest version of that codebase), and this advisory does not apply to those versions. ## Recommendation Upgrade to version 5.1.0.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | next (npm) | 0.9.9 to before 5.1.0 | 5.1.0 | Patch available | GHSA-5vj8-3v2h-h38v |
- next (npm) Vendor— Affected 0.9.9 to before 5.1.0 Fixed in 5.1.0 Patch available GHSA-5vj8-3v2h-h38v
Remediation
- Fix · GHSA-5vj8-3v2h-h38v next (npm) Fixed in 5.1.0 Advisory →
Timeline
- 2026-10-03 Threatist record created from GHSA-5vj8-3v2h-h38v
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences