Read the docs
TI-2020-19978 Aliases GHSA-9v62-24cr-58cx

Denial of Service in node-sass

Priority LOW 38CWE-400Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
Denial of service
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-400.

Summary

Affected versions of `node-sass` are vulnerable to Denial of Service (DoS). Crafted objects passed to the `renderSync` function may trigger C++ assertions in `CustomImporterBridge::get_importer_entry` and `CustomImporterBridge::post_process_return_value` that crash the Node process. This may allow attackers to crash the system's running Node process and lead to Denial of Service. ## Recommendation Upgrade to version 4.13.1 or later

Why it matters now

Fix Fixed node-sass (npm): 4.13.1

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—node-sass (npm)3.3.0 to before 4.13.14.13.1Patch availableGHSA-9v62-24cr-58cx
  • node-sass (npm) Vendor— Affected 3.3.0 to before 4.13.1 Fixed in 4.13.1 Patch available GHSA-9v62-24cr-58cx

Remediation

  • Fix · GHSA-9v62-24cr-58cx node-sass (npm) Fixed in 4.13.1 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-9v62-24cr-58cx

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences