Read the docs
TI-2020-19988 Aliases GHSA-8fw4-xh83-3j6q

Cross-Site Scripting in diagram-js

Priority LOW 38CWE-79Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
Cross-site scripting
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-79.

Summary

Versions of `diagram-js` prior to 3.3.1 (for 3.x) and 2.6.2 (for 2.x) are vulnerable to Cross-Site Scripting. The package fails to escape output of user-controlled input in `search-pad`, allowing attackers to execute arbitrary JavaScript. ## Recommendation If you are using diagram-js 3.x, upgrade to version 3.3.1. If you are using diagram-js 2.x, upgrade to version 2.6.2.

Why it matters now

Fix Fixed diagram-js (npm): 2.6.2, 3.3.1

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—diagram-js (npm)before 2.6.22.6.2Patch availableGHSA-8fw4-xh83-3j6q
—diagram-js (npm)3.0.0 to before 3.3.13.3.1Patch availableGHSA-8fw4-xh83-3j6q
  • diagram-js (npm) Vendor— Affected before 2.6.2 Fixed in 2.6.2 Patch available GHSA-8fw4-xh83-3j6q
  • diagram-js (npm) Vendor— Affected 3.0.0 to before 3.3.1 Fixed in 3.3.1 Patch available GHSA-8fw4-xh83-3j6q

Remediation

  • Fix · GHSA-8fw4-xh83-3j6q diagram-js (npm) Fixed in 2.6.2 Advisory →
  • Fix · GHSA-8fw4-xh83-3j6q diagram-js (npm) Fixed in 3.3.1 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-8fw4-xh83-3j6q

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences