Out-of-bounds write in Apple iOS and iPadOS
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-787 and the CVSS impact.
Summary
An out-of-bounds write was addressed with improved input validation. This issue is fixed in macOS Big Sur 11.2, Security Update 2021-001 Catalina, Security Update 2021-001 Mojave, watchOS 7.3, tvOS 14.4, iOS 14.4 and iPadOS 14.4. Processing a maliciously crafted image may lead to arbitrary code execution.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apple | iOS and iPadOS | before 14.4 | 14.4 | Patch available | CNA |
| Apple | macOS | before 11.2 | 11.2 | Patch available | CNA |
| Apple | macOS | before 7.3 | 7.3 | Patch available | CNA |
| Apple | macOS | before 14.4 | 14.4 | Patch available | CNA |
- iOS and iPadOS VendorApple Affected before 14.4 Fixed in 14.4 Patch available CNA
- macOS VendorApple Affected before 11.2 Fixed in 11.2 Patch available CNA
- macOS VendorApple Affected before 7.3 Fixed in 7.3 Patch available CNA
- macOS VendorApple Affected before 14.4 Fixed in 14.4 Patch available CNA
CPE configurations NVD · 9
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:apple:ipados:*:*:*:*:*:*:*:* | before 14.4 | Vulnerable | Apple |
| cpe:2.3:o:apple:iphone_os:*:*:*:*:*:*:*:* | before 14.4 | Vulnerable | Apple |
| cpe:2.3:o:apple:mac_os_x:*:*:*:*:*:*:*:* | 10.15 to before 10.15.7 | Vulnerable | Apple |
| cpe:2.3:o:apple:mac_os_x:10.15.7:-:*:*:*:*:*:* | 10.15.7 | Vulnerable | Apple |
| cpe:2.3:o:apple:mac_os_x:10.15.7:security_update_2020-001:*:*:*:*:*:* | 10.15.7 security_update_2020-001 | Vulnerable | Apple |
| cpe:2.3:o:apple:mac_os_x:10.15.7:supplemental_update:*:*:*:*:*:* | 10.15.7 supplemental_update | Vulnerable | Apple |
| cpe:2.3:o:apple:macos:*:*:*:*:*:*:*:* | 11.0.1 to before 11.2 | Vulnerable | Apple |
| cpe:2.3:o:apple:tvos:*:*:*:*:*:*:*:* | before 14.4 | Vulnerable | Apple |
| cpe:2.3:o:apple:watchos:*:*:*:*:*:*:*:* | before 7.3 | Vulnerable | Apple |
- cpe:2.3:o:apple:ipados:*:*:*:*:*:*:*:* Versions before 14.4 Vulnerable ·Apple
- cpe:2.3:o:apple:iphone_os:*:*:*:*:*:*:*:* Versions before 14.4 Vulnerable ·Apple
- cpe:2.3:o:apple:mac_os_x:*:*:*:*:*:*:*:* Versions 10.15 to before 10.15.7 Vulnerable ·Apple
- cpe:2.3:o:apple:mac_os_x:10.15.7:-:*:*:*:*:*:* Versions 10.15.7 Vulnerable ·Apple
- cpe:2.3:o:apple:mac_os_x:10.15.7:security_update_2020-001:*:*:*:*:*:* Versions 10.15.7 security_update_2020-001 Vulnerable ·Apple
- cpe:2.3:o:apple:mac_os_x:10.15.7:supplemental_update:*:*:*:*:*:* Versions 10.15.7 supplemental_update Vulnerable ·Apple
- cpe:2.3:o:apple:macos:*:*:*:*:*:*:*:* Versions 11.0.1 to before 11.2 Vulnerable ·Apple
- cpe:2.3:o:apple:tvos:*:*:*:*:*:*:*:* Versions before 14.4 Vulnerable ·Apple
- cpe:2.3:o:apple:watchos:*:*:*:*:*:*:*:* Versions before 7.3 Vulnerable ·Apple
Remediation
- Fix · CNA iOS and iPadOS (Apple) Fixed in 14.4
- Fix · CNA macOS (Apple) Fixed in 11.2
- Fix · CNA macOS (Apple) Fixed in 7.3
- Fix · CNA macOS (Apple) Fixed in 14.4
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Apple macOS 11.2
60 records Highest priority Priority CRITICAL 3 CRITICAL, 3 MEDIUM, 54 LOW
Other records, highest priority first
- TI-2021-01572 Apple iOS and iPadOS: A remote attacker may be able to cause arbitrary code executionPriority CRITICAL 100
- TI-2021-01502 Type confusion in Apple iOS and iPadOSPriority CRITICAL 97
- TI-2021-01495 Apple iOS and iPadOS: A malicious application may be able to elevate privilegesPriority CRITICAL 90
- Release ·
Apple iOS and iPadOS 14.4
49 records Highest priority Priority CRITICAL 3 CRITICAL, 1 HIGH, 6 MEDIUM, 39 LOW
Other records, highest priority first
- TI-2021-01572 Apple iOS and iPadOS: A remote attacker may be able to cause arbitrary code executionPriority CRITICAL 100
- TI-2021-01502 Type confusion in Apple iOS and iPadOSPriority CRITICAL 97
- TI-2021-01495 Apple iOS and iPadOS: A malicious application may be able to elevate privilegesPriority CRITICAL 90
Show 2 more groups
- Release ·
Apple macOS 14.4
35 records Highest priority Priority CRITICAL 2 CRITICAL, 2 MEDIUM, 31 LOW
Other records, highest priority first
- TI-2021-01502 Type confusion in Apple iOS and iPadOSPriority CRITICAL 97
- TI-2021-01495 Apple iOS and iPadOS: A malicious application may be able to elevate privilegesPriority CRITICAL 90
- TI-2021-01529 Apple iOS and iPadOS: A remote attacker may be able to cause unexpected application…Priority MEDIUM 47
- Release ·
Apple macOS 7.3
34 records Highest priority Priority CRITICAL 2 CRITICAL, 2 MEDIUM, 30 LOW
Other records, highest priority first
- TI-2021-01502 Type confusion in Apple iOS and iPadOSPriority CRITICAL 97
- TI-2021-01495 Apple iOS and iPadOS: A malicious application may be able to elevate privilegesPriority CRITICAL 90
- TI-2021-01529 Apple iOS and iPadOS: A remote attacker may be able to cause unexpected application…Priority MEDIUM 47
Timeline
- 2026-10-02 Threatist record created from CVE-2021-1744
- 2026-10-03 Alias added: GHSA-pfvx-gwp8-9rx2
References
More Apple Ipados vulnerabilities
- TI-2025-28008 Out-of-bounds write in Apple iOS and iPadOS KEVCVSS 3.1CRITICAL 10.0
- TI-2025-22441 Apple iOS and iPadOS: An attacker with arbitrary read and write capability may be able to… KEVCVSS 3.1CRITICAL 9.8
- TI-2025-22440 Memory corruption in Apple iOS and iPadOS KEVCVSS 3.1CRITICAL 9.8
- TI-2025-17951 Out-of-bounds write in Apple Safari KEVCVSS 3.1CRITICAL 10.0
- TI-2025-17847 Use after free in Apple iOS and iPadOS KEVCVSS 3.1CRITICAL 10.0
- TI-2022-06854 Out-of-bounds write in Apple iOS and iPadOS KEVCVSS 3.1CRITICAL 9.8
Sources
- CVE-2021-1744 · CVE Program
- CVE-2021-1744 · NVD
- FIRST EPSS
- GHSA-pfvx-gwp8-9rx2 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences