Read the docs
TI-2021-01512 Aliases CVE-2021-1800GHSA-7h33-2j5m-x48x

Apple Xcode: A malicious application may be able to access arbitrary files on the host…

Priority LOW 26Published · Updated

Key facts

Attack vector
Local
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
High · None · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA.

Summary

A path handling issue was addressed with improved validation. This issue is fixed in Xcode 12.4. A malicious application may be able to access arbitrary files on the host device while running an app that uses on-demand resources with Xcode.

Why it matters now

EPSS 0.00665 52nd percentileScored 2026-11-07
Fix Fixed Xcode (Apple): 12.4

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
AppleXcodebefore 12.412.4Patch availableCNA
  • Xcode VendorApple Affected before 12.4 Fixed in 12.4 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:apple:xcode:*:*:*:*:*:*:*:*before 12.4VulnerableApple
  • cpe:2.3:a:apple:xcode:*:*:*:*:*:*:*:* Versions before 12.4 Vulnerable ·Apple

Remediation

  • Fix · CNA Xcode (Apple) Fixed in 12.4

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-1800
  2. 2026-10-03 Alias added: GHSA-7h33-2j5m-x48x
  3. 2026-10-21 EPSS moved to the 50th–90th percentile

References

  • TI-2021-19919 Apache Log4j2 JNDI features do not protect against attacker controlled LDAP and other JNDI related endpoints KEVCVSS 3.1CRITICAL 10.0
  • TI-2025-30709 Git allows arbitrary code execution through broken config quoting KEVCVSS 3.1HIGH 8.1
  • TI-2004-02557 distcc 2.x, as used in XCode 1.5 and others, when not configured to restrict access to… CVSS 2.0HIGH 9.3
  • TI-2014-07619 Git before 1.8.5.6, 1.9.x before 1.9.5, 2.0.x before 2.0.5, 2.1.x before 2.1.4, and 2.2.x… CVSS 3.1CRITICAL 9.8
  • TI-2021-04400 malicious repositories can execute remote code while cloning CVSS 3.1HIGH 8.0
  • TI-2016-00666 The resolver in nginx before 1.8.1 and 1.9.x before 1.9.10 allows remote attackers to… CVSS 3.1HIGH 7.5
See all 99 →

Sources