Vulnerability in the OSS Support Tools product of Oracle Support Tools (component…
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
Vulnerability in the OSS Support Tools product of Oracle Support Tools (component: Diagnostic Assistant). The supported version that is affected is Prior to 2.12.41. Easily exploitable vulnerability allows high privileged attacker with network access via HTTP to compromise OSS Support Tools. Successful attacks of this vulnerability can result in unauthorized access to critical data or complete access to all OSS Support Tools accessible data. CVSS 3.1 Base Score 4.9 (Confidentiality impacts). CVSS Vector: (CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N).
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA OSS Support Tools (Oracle Corporation) Fixed in 2.12.41
Timeline
- 2026-10-02 Threatist record created from CVE-2021-2303
- 2026-10-03 Alias added: GHSA-gwhp-rphj-77jh
References
More Oracle Oss Support Tools vulnerabilities
- TI-2020-08897 Potential XSS vulnerability in jQuery KEVCVSS 3.1MEDIUM 6.9
- TI-2019-03845 Heap-based buffer overflow in curl CVSS 3.1HIGH 7.8
- TI-2019-03890 Heap buffer overflow in the TFTP protocol handler in cURL 7.19.4 to 7.65.3. CVSS 3.1CRITICAL 9.8
- TI-2018-01935 Vulnerability in the OSS Support Tools component of Oracle Support Tools (subcomponent… CVSS 3.0HIGH 8.8
- TI-2019-03889 Double-free vulnerability in the FTP-kerberos code in cURL 7.52.0 to 7.65.3. CVSS 3.1CRITICAL 9.8
- TI-2015-07630 jQuery before 3.0.0 is vulnerable to Cross-site Scripting (XSS) attacks when a… CVSS 3.0MEDIUM 6.1
Sources
- CVE-2021-2303 · CVE Program
- CVE-2021-2303 · NVD
- FIRST EPSS
- GHSA-gwhp-rphj-77jh · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences