Laminas Project laminas-http before 2.14.2, and Zend Framework 3.0.0, has a…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-502.
Summary
Laminas Project laminas-http before 2.14.2, and Zend Framework 3.0.0, has a deserialization vulnerability that can lead to remote code execution if the content is controllable, related to the __destruct method of the Zend\Http\Response\Stream class in Stream.php. NOTE: Zend Framework is no longer supported by the maintainer. NOTE: the laminas-http vendor considers this a "vulnerability in the PHP language itself" but has added certain type checking as a way to prevent exploitation in (unrecommended) use cases where attacker-supplied data can be deserialized
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | zendframework/zendframework (Packagist) | up to 3.0.0 | — | No fix listed | GHSA-xx8f-qf9f-5fgw |
| — | laminas/laminas-http (Packagist) | before 2.14.2 | 2.14.2 | Patch available | GHSA-xx8f-qf9f-5fgw |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- zendframework/zendframework (Packagist) Vendor— Affected up to 3.0.0 Fixed in — No fix listed GHSA-xx8f-qf9f-5fgw
- laminas/laminas-http (Packagist) Vendor— Affected before 2.14.2 Fixed in 2.14.2 Patch available GHSA-xx8f-qf9f-5fgw
Remediation
- Fix · GHSA-xx8f-qf9f-5fgw laminas/laminas-http (Packagist) Fixed in 2.14.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-3007
- 2026-10-03 Alias added: GHSA-xx8f-qf9f-5fgw
References
Exploit 2
Patch 2
Advisory 2
Sources
- CVE-2021-3007 · CVE Program
- CVE-2021-3007 · NVD
- FIRST EPSS
- GHSA-xx8f-qf9f-5fgw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences