Prisma Cloud: Cross-Site Scripting (XSS) Vulnerability in Prisma Cloud Compute Web Console
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- High
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
A reflected cross-site scripting (XSS) vulnerability exists in the Prisma Cloud Compute web console that enables a remote attacker to execute arbitrary JavaScript code in the browser-based web console while an authenticated administrator is using that web interface. Prisma Cloud Compute SaaS versions were automatically upgraded to the fixed release. No additional action is required for these instances. This issue impacts: Prisma Cloud Compute 20.12 versions earlier than Prisma Cloud Compute 20.12.552; Prisma Cloud Compute 21.04 versions earlier than Prisma Cloud Compute 21.04.439.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Palo Alto Networks | Prisma Cloud Compute | 21.04 to before 21.04.439; 20.12 to before 20.12.552 | 21.04.439, 20.12.552 | Patch available | CNA |
- Prisma Cloud Compute VendorPalo Alto Networks Affected 21.04 to before 21.04.439; 20.12 to before 20.12.552 Fixed in 21.04.439, 20.12.552 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:paloaltonetworks:prisma_cloud:*:*:*:*:compute:*:*:* | 20.12 to before 20.12.552; 21.04 to before 21.04.439 | Vulnerable | CyberArk Software, a Palo Alto Networks Company |
- cpe:2.3:a:paloaltonetworks:prisma_cloud:*:*:*:*:compute:*:*:* Versions 20.12 to before 20.12.552; 21.04 to before 21.04.439 Vulnerable ·CyberArk Software, a Palo Alto Networks Company
Remediation
- Fix · CNA Prisma Cloud Compute (Palo Alto Networks) Fixed in 21.04.439, 20.12.552
Timeline
- 2026-10-02 Threatist record created from CVE-2021-3043
- 2026-10-03 Alias added: GHSA-789j-5m28-p6v3
- 2026-10-25 EPSS moved to the 50th–90th percentile
References
More Palo Alto Networks vulnerabilities
- TI-2024-08782 Expedition: Unauthenticated OS Command Injection Vulnerability Leads to Firewall Credential Disclosure KEVCVSS 4.0CRITICAL 9.9
- TI-2024-03172 PAN-OS: Arbitrary File Creation Leads to OS Command Injection Vulnerability in GlobalProtect KEVCVSS 3.1CRITICAL 10.0
- TI-2020-01936 PAN-OS: Authentication Bypass in SAML Authentication KEVCVSS 3.1CRITICAL 10.0
- TI-2017-11675 Palo Alto Networks PAN-OS before 6.1.19, 7.0.x before 7.0.19, 7.1.x before 7.1.14, and… KEVCVSS 3.1CRITICAL 9.8
- TI-2026-00239 PAN-OS: Unauthenticated user initiated Buffer Overflow Vulnerability in User-ID™ Authentication Portal KEVCVSS 4.0CRITICAL 9.3
- TI-2024-08784 Expedition: SQL Injection Leads to Firewall Admin Credential Disclosure KEVCVSS 4.0CRITICAL 9.2
Sources
- CVE-2021-3043 · CVE Program
- CVE-2021-3043 · NVD
- FIRST EPSS
- GHSA-789j-5m28-p6v3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences