PAN-OS: OS Command Injection Vulnerability in Web Interface XML API
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-78.
Summary
An OS command injection vulnerability in the Palo Alto Networks PAN-OS web interface enables an authenticated administrator with permissions to use XML API the ability to execute arbitrary OS commands to escalate privileges. This issue impacts: PAN-OS 8.1 versions earlier than PAN-OS 8.1.20-h1; PAN-OS 9.0 versions earlier than PAN-OS 9.0.14-h3; PAN-OS 9.1 versions earlier than PAN-OS 9.1.11-h2; PAN-OS 10.0 versions earlier than PAN-OS 10.0.8; PAN-OS 10.1 versions earlier than PAN-OS 10.1.3. This issue does not impact Prisma Access firewalls.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Palo Alto Networks | PAN-OS | 10.1 to before 10.1.3; 9.0 to before 9.0.14-h3; 8.1 to before 8.1.20-h1; 9.1 to before 9.1.11-h2; 10.0 to before 10.0.8 | 10.1.3, 9.0.14-h3, 8.1.20-h1, 9.1.11-h2, 10.0.8 | Patch available | CNA |
| Palo Alto Networks | Prisma Access | — | 2.1 all, 2.2 all | Patch available | CNA |
- PAN-OS VendorPalo Alto Networks Affected 10.1 to before 10.1.3; 9.0 to before 9.0.14-h3; 8.1 to before 8.1.20-h1; 9.1 to before 9.1.11-h2; 10.0 to before 10.0.8 Fixed in 10.1.3, 9.0.14-h3, 8.1.20-h1, 9.1.11-h2, 10.0.8 Patch available CNA
- Prisma Access VendorPalo Alto Networks Affected — Fixed in 2.1 all, 2.2 all Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:paloaltonetworks:pan-os:*:*:*:*:*:*:*:* | 8.1.0 – 8.1.20; 9.0.0 – 9.0.14; 9.1.0 – 9.1.11; 10.0.0 to before 10.0.8; 10.1.0 to before 10.1.3 | Vulnerable | CyberArk Software, a Palo Alto Networks Company |
- cpe:2.3:o:paloaltonetworks:pan-os:*:*:*:*:*:*:*:* Versions 8.1.0 – 8.1.20; 9.0.0 – 9.0.14; 9.1.0 – 9.1.11; 10.0.0 to before 10.0.8; 10.1.0 to before 10.1.3 Vulnerable ·CyberArk Software, a Palo Alto Networks Company
Remediation
- Fix · CNA PAN-OS (Palo Alto Networks) Fixed in 10.1.3, 9.0.14-h3, 8.1.20-h1, 9.1.11-h2, 10.0.8
- Fix · CNA Prisma Access (Palo Alto Networks) Fixed in 2.1 all, 2.2 all
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Palo Alto Networks PAN-OS 10.0.8, 10.1.3 and 3 more versions
4 records Highest priority Priority MEDIUM 2 MEDIUM, 2 LOW
Other records, highest priority first
- TI-2021-02198 PAN-OS: OS Command Injection in Simple Certificate Enrollment Protocol (SCEP)Priority MEDIUM 60
- TI-2021-02197 PAN-OS: OS Command Injection Vulnerability When Performing Dynamic UpdatesPriority LOW 38
- TI-2021-02199 PAN-OS: OS Command Injection Vulnerability in the Command Line Interface (CLI)Priority LOW 33
Timeline
- 2026-10-02 Threatist record created from CVE-2021-3058
- 2026-10-03 Alias added: GHSA-jr79-8rh7-gxxh
References
More Palo Alto Networks vulnerabilities
- TI-2024-08782 Expedition: Unauthenticated OS Command Injection Vulnerability Leads to Firewall Credential Disclosure KEVCVSS 4.0CRITICAL 9.9
- TI-2024-03172 PAN-OS: Arbitrary File Creation Leads to OS Command Injection Vulnerability in GlobalProtect KEVCVSS 3.1CRITICAL 10.0
- TI-2020-01936 PAN-OS: Authentication Bypass in SAML Authentication KEVCVSS 3.1CRITICAL 10.0
- TI-2017-11675 Palo Alto Networks PAN-OS before 6.1.19, 7.0.x before 7.0.19, 7.1.x before 7.1.14, and… KEVCVSS 3.1CRITICAL 9.8
- TI-2026-00239 PAN-OS: Unauthenticated user initiated Buffer Overflow Vulnerability in User-ID™ Authentication Portal KEVCVSS 4.0CRITICAL 9.3
- TI-2024-08784 Expedition: SQL Injection Leads to Firewall Admin Credential Disclosure KEVCVSS 4.0CRITICAL 9.2
Sources
- CVE-2021-3058 · CVE Program
- CVE-2021-3058 · NVD
- FIRST EPSS
- GHSA-jr79-8rh7-gxxh · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences