PAN-OS: Improper Access Control Vulnerability Exposing AWS Instance Metadata Endpoint to GlobalProtect Users
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-284.
Summary
An improper access control vulnerability in PAN-OS software enables an attacker with authenticated access to GlobalProtect portals and gateways to connect to the EC2 instance metadata endpoint for VM-Series firewalls hosted on Amazon AWS. Exploitation of this vulnerability enables an attacker to perform any operations allowed by the EC2 role in AWS. This issue impacts: PAN-OS 8.1 versions earlier than PAN-OS 8.1.20 VM-Series firewalls; PAN-OS 9.1 versions earlier than PAN-OS 9.1.11 VM-Series firewalls; PAN-OS 9.0 versions earlier than PAN-OS 9.0.14 VM-Series firewalls; PAN-OS 10.0 versions earlier than PAN-OS 10.0.8 VM-Series firewalls. Prisma Access customers are not impacted by this issue.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Palo Alto Networks | PAN-OS | 9.1 to before 9.1.11; 8.1 to before 8.1.20; 9.0 to before 9.0.14; 10.0 to before 10.0.8 | 9.1.11, 8.1.20, 9.0.14, 10.0.8 | Patch available | CNA |
| Palo Alto Networks | Prisma Access | — | 2.1 all, 2.2 all | Patch available | CNA |
- PAN-OS VendorPalo Alto Networks Affected 9.1 to before 9.1.11; 8.1 to before 8.1.20; 9.0 to before 9.0.14; 10.0 to before 10.0.8 Fixed in 9.1.11, 8.1.20, 9.0.14, 10.0.8 Patch available CNA
- Prisma Access VendorPalo Alto Networks Affected — Fixed in 2.1 all, 2.2 all Patch available CNA
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:paloaltonetworks:pan-os:*:*:*:*:*:*:*:* | 8.1.0 to before 8.1.20; 9.0.0 to before 9.0.14; 9.1.0 to before 9.1.11; 10.0.0 to before 10.0.8 | Vulnerable | CyberArk Software, a Palo Alto Networks Company |
| cpe:2.3:a:paloaltonetworks:vm-series_firewall:-:*:*:*:*:*:*:* | not specified by NVD | Running on | CyberArk Software, a Palo Alto Networks Company |
- cpe:2.3:o:paloaltonetworks:pan-os:*:*:*:*:*:*:*:* Versions 8.1.0 to before 8.1.20; 9.0.0 to before 9.0.14; 9.1.0 to before 9.1.11; 10.0.0 to before 10.0.8 Vulnerable ·CyberArk Software, a Palo Alto Networks Company
- cpe:2.3:a:paloaltonetworks:vm-series_firewall:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·CyberArk Software, a Palo Alto Networks Company
Remediation
- Fix · CNA PAN-OS (Palo Alto Networks) Fixed in 9.1.11, 8.1.20, 9.0.14, 10.0.8
- Fix · CNA Prisma Access (Palo Alto Networks) Fixed in 2.1 all, 2.2 all
Timeline
- 2026-10-02 Threatist record created from CVE-2021-3062
- 2026-10-03 Alias added: GHSA-fr5v-rgrp-ghw9
References
More Palo Alto Networks vulnerabilities
- TI-2024-08782 Expedition: Unauthenticated OS Command Injection Vulnerability Leads to Firewall Credential Disclosure KEVCVSS 4.0CRITICAL 9.9
- TI-2024-03172 PAN-OS: Arbitrary File Creation Leads to OS Command Injection Vulnerability in GlobalProtect KEVCVSS 3.1CRITICAL 10.0
- TI-2020-01936 PAN-OS: Authentication Bypass in SAML Authentication KEVCVSS 3.1CRITICAL 10.0
- TI-2017-11675 Palo Alto Networks PAN-OS before 6.1.19, 7.0.x before 7.0.19, 7.1.x before 7.1.14, and… KEVCVSS 3.1CRITICAL 9.8
- TI-2026-00239 PAN-OS: Unauthenticated user initiated Buffer Overflow Vulnerability in User-ID™ Authentication Portal KEVCVSS 4.0CRITICAL 9.3
- TI-2024-08784 Expedition: SQL Injection Leads to Firewall Admin Credential Disclosure KEVCVSS 4.0CRITICAL 9.2
Sources
- CVE-2021-3062 · CVE Program
- CVE-2021-3062 · NVD
- FIRST EPSS
- GHSA-fr5v-rgrp-ghw9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences