Zen Cart 1.5.7b allows admins to execute arbitrary OS commands by inspecting an HTML…
Priority MEDIUM 49CWE-78Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-78.
Summary
Zen Cart 1.5.7b allows admins to execute arbitrary OS commands by inspecting an HTML radio input element (within the modules edit page) and inserting a command.
Why it matters now
EPSS 0.16976 97th percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by NVD
Fix Fixed zencart/zencart (Packagist): 1.5.7c
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | zencart/zencart (Packagist) | before 1.5.7c | 1.5.7c | Patch available | GHSA-38f9-4vhq-9cr8 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- zencart/zencart (Packagist) Vendor— Affected before 1.5.7c Fixed in 1.5.7c Patch available GHSA-38f9-4vhq-9cr8
Remediation
- Fix · GHSA-38f9-4vhq-9cr8 zencart/zencart (Packagist) Fixed in 1.5.7c Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-3291
- 2026-10-03 Alias added: GHSA-38f9-4vhq-9cr8
References
Exploit 2
More Zen Cart vulnerabilities
- TI-2024-05349 Zen Cart findPluginAdminPage Local File Inclusion Remote Code Execution Vulnerability CVSS 3.1HIGH 8.1
- TI-2015-06874 Directory traversal vulnerability in Zen Cart 1.5.4 allows remote attackers to include… CVSS 3.0CRITICAL 9.8
- TI-2009-02152 Zen Cart 1.3.8a, 1.3.8, and earlier does not require administrative authentication for… CVSS 2.0MEDIUM 6.8
- TI-2006-00676 Zen Cart before 1.2.7 does not protect the admin/includes directory, which allows remote… CVSS 2.0HIGH 10.0
- TI-2009-02151 Zen Cart 1.3.8a, 1.3.8, and earlier does not require administrative authentication for… CVSS 2.0HIGH 7.5
- TI-2017-08647 The traverseStrictSanitize function in… CVSS 3.0HIGH 8.8
Sources
- CVE-2021-3291 · CVE Program
- CVE-2021-3291 · NVD
- FIRST EPSS
- GHSA-38f9-4vhq-9cr8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences