The npm package ansi_up converts ANSI escape codes into HTML.
Priority LOW 38CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Partial Red Hat: 1 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-79.
Summary
The npm package ansi_up converts ANSI escape codes into HTML. In ansi_up v4, ANSI escape codes can be used to create HTML hyperlinks. Due to insufficient URL sanitization, this feature is affected by a cross-site scripting (XSS) vulnerability. This issue is fixed in v5.0.0.
Why it matters now
EPSS 0.08 94th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Partial ansi_up (npm): 5.0.0Red Hat: 1 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | ansi_up (npm) | before 5.0.0 | 5.0.0 | Patch available | GHSA-2v5f-23xc-v9qr |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- ansi_up (npm) Vendor— Affected before 5.0.0 Fixed in 5.0.0 Patch available GHSA-2v5f-23xc-v9qr
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:ansi_up_project:ansi_up:*:*:*:*:*:node.js:*:* | before 5.0.0 | Vulnerable | Ansi Up Project |
- cpe:2.3:a:ansi_up_project:ansi_up:*:*:*:*:*:node.js:*:* Versions before 5.0.0 Vulnerable ·Ansi Up Project
Remediation
- Fix · GHSA-2v5f-23xc-v9qr ansi_up (npm) Fixed in 5.0.0 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Advanced Cluster Management for Kubernetes 2 | Affected | No fix yet |
Timeline
- 2026-10-02 Threatist record created from CVE-2021-3377
- 2026-10-03 Alias added: GHSA-2v5f-23xc-v9qr
References
Sources
- CVE-2021-3377 · CVE Program
- CVE-2021-3377 · NVD
- FIRST EPSS
- GHSA-2v5f-23xc-v9qr · GitHub Advisory Database · CC BY 4.0
- CVE-2021-3377 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences