Cross-site scripting in Deluge-web
Priority LOW 29CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
The Deluge Web-UI is vulnerable to XSS through a crafted torrent file. The the data from torrent files is not properly sanitised as it's interpreted directly as HTML. Someone who supplies the user with a malicious torrent file can execute arbitrary Javascript code in the context of the user's browser session.
Why it matters now
EPSS 0.00959 61st percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by NVD
Fix Fixed deluge (PyPI): 2.1.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | Deluge-web | Not-Known | — | No fix listed | CNA |
| — | deluge (PyPI) | before 2.1.0 | 2.1.0 | Patch available | GHSA-5c8p-qhch-qhx6 |
- Deluge-web Vendor— Affected Not-Known Fixed in — No fix listed CNA
- deluge (PyPI) Vendor— Affected before 2.1.0 Fixed in 2.1.0 Patch available GHSA-5c8p-qhch-qhx6
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:deluge-torrent:deluge:*:*:*:*:*:*:*:* | before 2.1.0 | Vulnerable | Deluge-torrent |
- cpe:2.3:a:deluge-torrent:deluge:*:*:*:*:*:*:*:* Versions before 2.1.0 Vulnerable ·Deluge-torrent
Remediation
- Fix · GHSA-5c8p-qhch-qhx6 deluge (PyPI) Fixed in 2.1.0 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2021-3427
- 2026-10-03 Alias added: GHSA-5c8p-qhch-qhx6
References
Exploit 2
Advisory 3
More Deluge-torrent Deluge vulnerabilities
- TI-2019-15639 Deluge 1.3.15 Denial of Service via URL Field CVSS 4.0MEDIUM 6.9
- TI-2019-15638 Deluge 1.3.15 Denial of Service via Webseeds Field CVSS 4.0MEDIUM 6.9
- TI-2017-06496 The WebUI component in Deluge before 1.3.15 contains a directory traversal vulnerability… CVSS 3.0CRITICAL 9.8
- TI-2017-04877 CSRF was discovered in the web UI in Deluge before 1.3.14. CVSS 3.1HIGH 8.8
Sources
- CVE-2021-3427 · CVE Program
- CVE-2021-3427 · NVD
- FIRST EPSS
- GHSA-5c8p-qhch-qhx6 · GitHub Advisory Database · CC BY 4.0
- CVE-2021-3427 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences