Improper access control in Bitdefender Endpoint Security Tools for Linux
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-284.
Summary
Improper Access Control vulnerability in the patchesUpdate API as implemented in Bitdefender Endpoint Security Tools for Linux as a relay role allows an attacker to manipulate the remote address used for pulling patches. This issue affects: Bitdefender Endpoint Security Tools for Linux versions prior to 6.6.27.390; versions prior to 7.1.2.33. Bitdefender Unified Endpoint versions prior to 6.2.21.160. Bitdefender GravityZone versions prior to 6.24.1-1.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Bitdefender | Endpoint Security Tools for Linux | before 6.6.27.390; before 7.1.2.33 | 6.6.27.390, 7.1.2.33 | Patch available | CNA |
| Bitdefender | Unified Endpoint | before 6.2.21.160 | 6.2.21.160 | Patch available | CNA |
| Bitdefender | GravityZone | before 6.24.1-1 | 6.24.1-1 | Patch available | CNA |
- Endpoint Security Tools for Linux VendorBitdefender Affected before 6.6.27.390; before 7.1.2.33 Fixed in 6.6.27.390, 7.1.2.33 Patch available CNA
- Unified Endpoint VendorBitdefender Affected before 6.2.21.160 Fixed in 6.2.21.160 Patch available CNA
- GravityZone VendorBitdefender Affected before 6.24.1-1 Fixed in 6.24.1-1 Patch available CNA
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:bitdefender:endpoint_security_tools:*:*:*:*:*:*:*:* | before 6.6.27.390 | Vulnerable | Bitdefender |
| cpe:2.3:a:bitdefender:endpoint_security_tools:*:*:*:*:*:linux:*:* | before 6.6.27.390 | Vulnerable | Bitdefender |
| cpe:2.3:a:bitdefender:endpoint_security_tools:*:*:*:*:*:*:*:* | 7.0.0.00 to before 7.1.2.33 | Vulnerable | Bitdefender |
| cpe:2.3:a:bitdefender:gravityzone:*:*:*:*:*:*:*:* | before 6.24.1-1 | Vulnerable | Bitdefender |
| cpe:2.3:a:bitdefender:gravityzone:6.24.1-1:*:*:*:*:*:*:* | 6.24.1-1 | Vulnerable | Bitdefender |
- cpe:2.3:a:bitdefender:endpoint_security_tools:*:*:*:*:*:*:*:* Versions before 6.6.27.390 Vulnerable ·Bitdefender
- cpe:2.3:a:bitdefender:endpoint_security_tools:*:*:*:*:*:linux:*:* Versions before 6.6.27.390 Vulnerable ·Bitdefender
- cpe:2.3:a:bitdefender:endpoint_security_tools:*:*:*:*:*:*:*:* Versions 7.0.0.00 to before 7.1.2.33 Vulnerable ·Bitdefender
- cpe:2.3:a:bitdefender:gravityzone:*:*:*:*:*:*:*:* Versions before 6.24.1-1 Vulnerable ·Bitdefender
- cpe:2.3:a:bitdefender:gravityzone:6.24.1-1:*:*:*:*:*:*:* Versions 6.24.1-1 Vulnerable ·Bitdefender
Remediation
- Fix · CNA Endpoint Security Tools for Linux (Bitdefender) Fixed in 6.6.27.390, 7.1.2.33
- Fix · CNA Unified Endpoint (Bitdefender) Fixed in 6.2.21.160
- Fix · CNA GravityZone (Bitdefender) Fixed in 6.24.1-1
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Bitdefender GravityZone 6.24.1-1
2 records Highest priority Priority MEDIUM 1 MEDIUM, 1 LOW
Other records, highest priority first
- TI-2021-02506 Server-Side Request Forgery in EPPUpdateService remote config file (VA-9825)Priority LOW 35
Timeline
- 2026-10-02 Threatist record created from CVE-2021-3554
- 2026-10-03 Alias added: GHSA-6wjr-cr9m-279q
References
More Bitdefender Endpoint Security Tools vulnerabilities
- TI-2025-06435 Local Privilege Escalation via Arbitrary File Operation in Bitdefender Total Security CVSS 4.0HIGH 8.8
- TI-2021-02525 Privilege escalation via SeImpersonatePrivilege CVSS 3.1HIGH 7.8
- TI-2021-02505 Insufficient validation on regular expression in EPPUpdateService config file (VA-9825) CVSS 3.1HIGH 7.5
- TI-2022-00592 Improper Handling of Length Parameter Inconsistency vulnerability in Bitdefender Update Server (VA-10144) CVSS 3.1HIGH 7.5
- TI-2021-03065 Incorrect Permission Assignment for Critical Resource vulnerability in BDReinit.exe (VA-10017) CVSS 3.1HIGH 7.8
- TI-2021-02528 Incorrect Default Permissions vulnerability in bdservicehost.exe and Vulnerability.Scan.exe CVSS 3.1HIGH 7.8
Sources
- CVE-2021-3554 · CVE Program
- CVE-2021-3554 · NVD
- FIRST EPSS
- GHSA-6wjr-cr9m-279q · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences