Improper input validation in ansible
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Partial Red Hat: 5 fixed, 1 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-94.
Summary
A flaw was found in Ansible, where a user's controller is vulnerable to template injection. This issue can occur through facts used in the template if the user is trying to put templates in multi-line YAML strings and the facts being handled do not routinely include special template characters. This flaw allows attackers to perform command injection, which discloses sensitive information. The highest threat from this vulnerability is to confidentiality and integrity.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | ansible | ansible_tower 3.7, ansible_engine 2.9.23 | — | No fix listed | CNA |
| — | ansible (PyPI) | before 2.9.23rc1 | 2.9.23rc1 | Patch available | GHSA-2pfh-q76x-gwvm |
| — | ansible (PyPI) | 2.10.0a1 to before 2.10.11rc1 | 2.10.11rc1 | Patch available | GHSA-2pfh-q76x-gwvm |
| — | ansible (PyPI) | 2.11.0a1 to before 2.11.2rc1 | 2.11.2rc1 | Patch available | GHSA-2pfh-q76x-gwvm |
- ansible Vendor— Affected ansible_tower 3.7, ansible_engine 2.9.23 Fixed in — No fix listed CNA
- ansible (PyPI) Vendor— Affected before 2.9.23rc1 Fixed in 2.9.23rc1 Patch available GHSA-2pfh-q76x-gwvm
- ansible (PyPI) Vendor— Affected 2.10.0a1 to before 2.10.11rc1 Fixed in 2.10.11rc1 Patch available GHSA-2pfh-q76x-gwvm
- ansible (PyPI) Vendor— Affected 2.11.0a1 to before 2.11.2rc1 Fixed in 2.11.2rc1 Patch available GHSA-2pfh-q76x-gwvm
Remediation
- Fix · GHSA-2pfh-q76x-gwvm ansible (PyPI) Fixed in 2.9.23rc1 Advisory →
- Fix · GHSA-2pfh-q76x-gwvm ansible (PyPI) Fixed in 2.10.11rc1 Advisory →
- Fix · GHSA-2pfh-q76x-gwvm ansible (PyPI) Fixed in 2.11.2rc1 Advisory →
Red Hat 2 advisories
- RHSA-2021:2664 Released 2021-07-07 · Red Hat rating ImportantAnsible security and bug fix update (2.9.23)
- Red Hat Ansible Engine 2 for RHEL 7 ansible-2.9.23-1.el7ae, ansible-test-2.9.23-1.el7ae
- Red Hat Ansible Engine 2 for RHEL 8 ansible-2.9.23-1.el8ae, ansible-test-2.9.23-1.el8ae
- RHSA-2021:2663 Released 2021-07-07 · Red Hat rating ImportantAnsible security and bug fix update (2.9.23)
- Red Hat Ansible Engine 2.9 for RHEL 7 Server ansible-2.9.23-1.el7ae, ansible-test-2.9.23-1.el7ae
- Red Hat Ansible Engine 2.9 for RHEL 8 ansible-2.9.23-1.el8ae, ansible-test-2.9.23-1.el8ae
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Ansible Tower 3 | Affected | No fix yet |
| Red Hat Ansible Automation Platform 2.0 for RHEL 8 | Fixed | — |
| Red Hat Ansible Engine 2 for RHEL 7 | Fixed | RHSA-2021:2664 |
| Red Hat Ansible Engine 2 for RHEL 8 | Fixed | RHSA-2021:2664 |
| Red Hat Ansible Engine 2.9 for RHEL 7 Server | Fixed | RHSA-2021:2663 |
| Red Hat Ansible Engine 2.9 for RHEL 8 | Fixed | RHSA-2021:2663 |
Not affected: 1 product
- Red Hat Ansible Automation Platform 2.0 for RHEL 8
Timeline
- 2026-10-02 Threatist record created from CVE-2021-3583
- 2026-10-03 Alias added: GHSA-2pfh-q76x-gwvm
References
Advisory 3
Other 7
- [debian-lts-announce] 20231228 [SECURITY] [DLA 3695-1] ansible security update
- https://github.com/ansible/ansible/pull/74960
- https://github.com/ansible/ansible/commit/03aff644cc1c00e1f7551195c68fbd0d13a39e6e
- https://github.com/ansible/ansible/commit/8aa850e3573e48c9a2f12aef84e8a3a6f5ba4847
- https://github.com/ansible/ansible/commit/8b17e5b9229ffaecfe10a4881bc3f87dd2c184e1
- https://github.com/ansible/ansible
- https://github.com/pypa/advisory-database/tree/main/vulns/ansible/PYSEC-2021-358.yaml
More Red Hat Ansible Automation Platform vulnerabilities
- TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
- TI-2026-35991 Starlette has missing Host header validation that poisons request.url.path, bypassing path-based security checks KEVCVSS 3.1MEDIUM 6.5
- TI-2026-34281 JavaScript Cookie: Per-instance prototype hijack in assign() enables cookie-attribute injection CVSS 3.1HIGH 7.5
- TI-2026-28834 jq: Out-of-Bounds Read in jv_parse_sized() Error Formatting for Non-NUL-Terminated Counted Buffers CVSS 4.0MEDIUM 6.9
- TI-2026-32429 Axios: Credential Theft and Response Hijacking via Prototype Pollution Gadget in Config Merge CVSS 3.1HIGH 7.7
- TI-2023-27712 Python-cryptography: bleichenbacher timing oracle attack against rsa decryption - incomplete fix for cve-2020-25659 CVSS 3.1HIGH 7.5
Sources
- CVE-2021-3583 · CVE Program
- CVE-2021-3583 · NVD
- FIRST EPSS
- GHSA-2pfh-q76x-gwvm · GitHub Advisory Database · CC BY 4.0
- CVE-2021-3583 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences