Use after free in QEMU
Key facts
- Attack vector
- Local
- Privileges required
- High
- User interaction
- None
- Attack complexity
- High
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Partial Red Hat: 5 fixed, 5 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and Red Hat. Impact type from CWE-416 and the CVSS impact.
Summary
A use-after-free vulnerability was found in the virtio-net device of QEMU. It could occur when the descriptor's address belongs to the non direct access region, due to num_buffers being set after the virtqueue elem has been unmapped. A malicious guest could use this flaw to crash QEMU, resulting in a denial of service condition, or potentially execute code on the host with the privileges of the QEMU process.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | QEMU (virtio-net) | Affects qemu v0.10.0 and above, Fixed In – v6.2.0-rc0 and above. | — | No fix listed | CNA |
- QEMU (virtio-net) Vendor— Affected Affects qemu v0.10.0 and above, Fixed In – v6.2.0-rc0 and above. Fixed in — No fix listed CNA
CPE configurations NVD · 9
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:qemu:qemu:*:*:*:*:*:*:*:* | 0.10.0 to before 6.2.0 | Vulnerable | QEMU |
| cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* | 10.0 | Vulnerable | Debian |
| cpe:2.3:o:canonical:ubuntu_linux:18.04:*:*:*:lts:*:*:* | 18.04 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:20.04:*:*:*:lts:*:*:* | 20.04 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:21.10:*:*:*:*:*:*:* | 21.10 | Vulnerable | Canonical |
| cpe:2.3:o:fedoraproject:fedora:34:*:*:*:*:*:*:* | 34 | Vulnerable | Fedoraproject |
| cpe:2.3:o:redhat:enterprise_linux:8.0:*:*:*:advanced_virtualization:*:*:* | 8.0 | Vulnerable | Red Hat |
| cpe:2.3:o:redhat:enterprise_linux_advanced_virtualization_eus:8.4:*:*:*:*:*:*:* | 8.4 | Vulnerable | Red Hat |
- cpe:2.3:a:qemu:qemu:*:*:*:*:*:*:*:* Versions 0.10.0 to before 6.2.0 Vulnerable ·QEMU
- cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
- cpe:2.3:o:canonical:ubuntu_linux:18.04:*:*:*:lts:*:*:* Versions 18.04 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:20.04:*:*:*:lts:*:*:* Versions 20.04 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:21.10:*:*:*:*:*:*:* Versions 21.10 Vulnerable ·Canonical
- cpe:2.3:o:fedoraproject:fedora:34:*:*:*:*:*:*:* Versions 34 Vulnerable ·Fedoraproject
- cpe:2.3:o:redhat:enterprise_linux:8.0:*:*:*:advanced_virtualization:*:*:* Versions 8.0 Vulnerable ·Red Hat
- cpe:2.3:o:redhat:enterprise_linux_advanced_virtualization_eus:8.4:*:*:*:*:*:*:* Versions 8.4 Vulnerable ·Red Hat
Remediation
Red Hat 3 advisories
- RHSA-2022:1759 Released 2022-05-10 · Red Hat rating Moderatevirt:rhel and virt-devel:rhel security, bug fix, and enhancement update
- Red Hat Enterprise Linux AppStream (v. 8) SLOF-20210217-1.module+el8.6.0+14480+c0a3aa0f.noarch::virt:rhel, SLOF-20210217-1.module+el8.6.0+14480+c0a3aa0f.src::virt:rhel, hivex-1.3.18-23.module+el8.6.0+14480+c0a3aa0f.aarch64::virt:rhel +47
- Red Hat Enterprise Linux CRB (v. 8) SLOF-20210217-1.module+el8.6.0+14480+c0a3aa0f.src::virt-devel:rhel, hivex-1.3.18-23.module+el8.6.0+14480+c0a3aa0f.i686::virt-devel:rhel, hivex-devel-1.3.18-23.module+el8.6.0+14480+c0a3aa0f.i686::virt-devel:rhel +47
- RHSA-2021:5036 Released 2021-12-09 · Red Hat rating Moderatevirt:8.2 and virt-devel:8.2 security update
- Advanced Virtualization CodeReady Builder for RHEL 8.2.1 SLOF-20191022-3.git899d9883.module+el8.2.0+5449+efc036dd.src::virt-devel:8.2, hivex-1.3.18-20.module+el8.2.0+5588+63a201c3.i686::virt-devel:8.2, hivex-devel-1.3.18-20.module+el8.2.0+5588+63a201c3.i686::virt-devel:8.2 +47
- Advanced Virtualization for RHEL 8.2.1 SLOF-20191022-3.git899d9883.module+el8.2.0+5449+efc036dd.noarch::virt:8.2, SLOF-20191022-3.git899d9883.module+el8.2.0+5449+efc036dd.src::virt:8.2, hivex-1.3.18-20.module+el8.2.0+5588+63a201c3.aarch64::virt:8.2 +47
- RHSA-2021:4112 Released 2021-11-03 · Red Hat rating Moderatevirt:av and virt-devel:av security and bug fix update
- Advanced Virtualization for RHEL 8.4.0.Z SLOF-20200717-1.gite18ddad8.module+el8.4.0+8855+a9e237a9.noarch::virt:av, SLOF-20200717-1.gite18ddad8.module+el8.4.0+8855+a9e237a9.src::virt-devel:av, SLOF-20200717-1.gite18ddad8.module+el8.4.0+8855+a9e237a9.src::virt:av +47
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 6 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 7 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 8 Advanced Virtualization | Affected | No fix yet |
| Red Hat OpenStack Platform 10 (Newton) | Affected | No fix planned: Out of support scope |
| Red Hat OpenStack Platform 13 (Queens) | Affected | No fix planned: Out of support scope |
| Advanced Virtualization CodeReady Builder for RHEL 8.2.1 | Fixed | RHSA-2021:5036 |
| Advanced Virtualization for RHEL 8.2.1 | Fixed | RHSA-2021:5036 |
| Advanced Virtualization for RHEL 8.4.0.Z | Fixed | RHSA-2021:4112 |
| Red Hat Enterprise Linux AppStream (v. 8) | Fixed | RHSA-2022:1759 |
| Red Hat Enterprise Linux CRB (v. 8) | Fixed | RHSA-2022:1759 |
Not affected: 1 product
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2021-3748
- 2026-10-03 Alias added: GHSA-4f87-mww8-gm8x
References
Patch 4
Sources
- CVE-2021-3748 · CVE Program
- CVE-2021-3748 · NVD
- FIRST EPSS
- GHSA-4f87-mww8-gm8x · GitHub Advisory Database · CC BY 4.0
- CVE-2021-3748 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences