Information disclosure in Glib
Priority LOW 26CWE-200Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Partial Red Hat: 2 fixed, 3 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and Red Hat. Impact type from CWE-200.
Summary
A flaw was found in glib before version 2.63.6. Due to random charset alias, pkexec can leak content from files owned by privileged users to unprivileged ones under the right condition.
Why it matters now
EPSS 0.00565 47th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Partial Red Hat: 1 advisoryRed Hat: 2 fixed, 3 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | Glib | Fixed in glib2 2.63.6 | — | No fix listed | CNA |
- Glib Vendor— Affected Fixed in glib2 2.63.6 Fixed in — No fix listed CNA
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:gnome:glib:*:*:*:*:*:*:*:* | before 2.62.5; 2.63.0 to before 2.63.6 | Vulnerable | GNOME |
| cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* | 10.0 | Vulnerable | Debian |
| cpe:2.3:a:netapp:active_iq_unified_manager:-:*:*:*:*:vmware_vsphere:*:* | not specified by NVD | Vulnerable | NetApp |
- cpe:2.3:a:gnome:glib:*:*:*:*:*:*:*:* Versions before 2.62.5; 2.63.0 to before 2.63.6 Vulnerable ·GNOME
- cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
- cpe:2.3:a:netapp:active_iq_unified_manager:-:*:*:*:*:vmware_vsphere:*:* Versions not specified by NVD Vulnerable ·NetApp
Remediation
Red Hat 1 advisory
- RHSA-2021:4385 Released 2021-11-09 · Red Hat rating Moderateglib2 security and bug fix update
- Red Hat CodeReady Linux Builder (v. 8) glib2-doc-2.56.4-156.el8, glib2-static-2.56.4-156.el8
- Red Hat Enterprise Linux BaseOS (v. 8) glib2-2.56.4-156.el8, glib2-devel-2.56.4-156.el8, glib2-fam-2.56.4-156.el8 +1
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 6 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 7 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 8 | Affected | No fix planned: Will not fix |
| Red Hat CodeReady Linux Builder (v. 8) | Fixed | RHSA-2021:4385 |
| Red Hat Enterprise Linux BaseOS (v. 8) | Fixed | RHSA-2021:4385 |
Not affected: 2 products
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2021-3800
- 2026-10-03 Alias added: GHSA-58w9-h6f7-f979
References
Patch 2
Sources
- CVE-2021-3800 · CVE Program
- CVE-2021-3800 · NVD
- FIRST EPSS
- GHSA-58w9-h6f7-f979 · GitHub Advisory Database · CC BY 4.0
- CVE-2021-3800 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences