Read the docs
TI-2021-02771 Aliases CVE-2021-3840GHSA-hgc3-hp6x-wpgx

Uncontrolled search path in Antilles

Priority MEDIUM 42CWE-427Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-427.

Summary

A dependency confusion vulnerability was reported in the Antilles open-source software prior to version 1.0.1 that could allow for remote code execution during installation due to a package listed in requirements.txt not existing in the public package index (PyPi). MITRE classifies this weakness as an Uncontrolled Search Path Element (CWE-427) in which a private package dependency may be replaced by an unauthorized package of the same name published to a well-known public repository such as PyPi. The configuration has been updated to only install components built by Antilles, removing all other public package indexes. Additionally, the antilles-tools dependency has been published to PyPi.

Why it matters now

EPSS 0.02036 81st percentileScored 2026-11-07
Fix Fixed Antilles (Antilles): 1.0.1antilles-tools (PyPI): 1.0.1

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
AntillesAntillesbefore 1.0.11.0.1Patch availableCNA
—antilles-tools (PyPI)before 1.0.11.0.1Patch availableGHSA-hgc3-hp6x-wpgx
  • Antilles VendorAntilles Affected before 1.0.1 Fixed in 1.0.1 Patch available CNA
  • antilles-tools (PyPI) Vendor— Affected before 1.0.1 Fixed in 1.0.1 Patch available GHSA-hgc3-hp6x-wpgx

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:lenovo:antilles:*:*:*:*:*:*:*:*before 1.0.1VulnerableLenovo
  • cpe:2.3:a:lenovo:antilles:*:*:*:*:*:*:*:* Versions before 1.0.1 Vulnerable ·Lenovo

Remediation

  • Fix · CNA Antilles (Antilles) Fixed in 1.0.1
  • Fix · GHSA-hgc3-hp6x-wpgx antilles-tools (PyPI) Fixed in 1.0.1 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-3840
  2. 2026-10-03 Alias added: GHSA-hgc3-hp6x-wpgx

References

Sources