Heap-based Buffer Overflow in vim/vim
Priority LOW 35CWE-122Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Partial Red Hat: 2 fixed, 2 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and Red Hat. Impact type from CWE-122 and the CVSS impact.
Summary
vim is vulnerable to Heap-based Buffer Overflow
Why it matters now
EPSS 0.00646 51st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Partial vim/vim (vim): 8.2.3564Red Hat: 1 advisoryRed Hat: 2 fixed, 2 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| vim | vim/vim | before 8.2.3564 | 8.2.3564 | Patch available | CNA |
- vim/vim Vendorvim Affected before 8.2.3564 Fixed in 8.2.3564 Patch available CNA
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:vim:vim:*:*:*:*:*:*:*:* | before 8.2.3564 | Vulnerable | vim |
| cpe:2.3:o:fedoraproject:fedora:33:*:*:*:*:*:*:* | 33 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:34:*:*:*:*:*:*:* | 34 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:35:*:*:*:*:*:*:* | 35 | Vulnerable | Fedoraproject |
| cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Debian |
- cpe:2.3:a:vim:vim:*:*:*:*:*:*:*:* Versions before 8.2.3564 Vulnerable ·vim
- cpe:2.3:o:fedoraproject:fedora:33:*:*:*:*:*:*:* Versions 33 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:34:*:*:*:*:*:*:* Versions 34 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:35:*:*:*:*:*:*:* Versions 35 Vulnerable ·Fedoraproject
- cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
Remediation
- Fix · CNA vim/vim (vim) Fixed in 8.2.3564
Red Hat 1 advisory
- RHSA-2024:9405 Released 2024-11-12 · Red Hat rating Lowvim security update
- Red Hat Enterprise Linux AppStream (v. 9) vim-X11-2:8.2.2637-21.el9, vim-common-2:8.2.2637-21.el9, vim-enhanced-2:8.2.2637-21.el9
- Red Hat Enterprise Linux BaseOS (v. 9) vim-2:8.2.2637-21.el9, vim-filesystem-2:8.2.2637-21.el9, vim-minimal-2:8.2.2637-21.el9
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 6 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 7 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux AppStream (v. 9) | Fixed | RHSA-2024:9405 |
| Red Hat Enterprise Linux BaseOS (v. 9) | Fixed | RHSA-2024:9405 |
Not affected: 2 products
- Red Hat Advanced Cluster Management for Kubernetes 2
- Red Hat Enterprise Linux 8
Timeline
- 2026-10-02 Threatist record created from CVE-2021-3903
- 2026-10-03 Alias added: GHSA-xc29-p9xx-c3j9
- 2026-10-19 EPSS moved to the 50th–90th percentile
References
More Vim vulnerabilities
- TI-2022-03248 Heap-based Buffer Overflow in vim/vim CVSS 3.1CRITICAL 9.8
- TI-2024-15103 Vim before 9.0.2142 has a stack-based buffer overflow because did_set_langmap in map.c… CVSS 3.1HIGH 7.8
- TI-2023-05093 Use After Free in vim/vim CVSS 3.1HIGH 7.8
- TI-2023-04407 Heap-based Buffer Overflow in vim/vim CVSS 3.1HIGH 7.8
- TI-2023-04379 Heap-based Buffer Overflow in vim/vim CVSS 3.1HIGH 7.8
- TI-2023-04378 Use After Free in vim/vim CVSS 3.1HIGH 7.8
Sources
- CVE-2021-3903 · CVE Program
- CVE-2021-3903 · NVD
- FIRST EPSS
- GHSA-xc29-p9xx-c3j9 · GitHub Advisory Database · CC BY 4.0
- CVE-2021-3903 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences