Free of static data in accountsservice
Priority LOW 34CWE-590Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- High
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
Ubuntu-specific modifications to accountsservice (in patch file debian/patches/0010-set-language.patch) caused the fallback_locale variable, pointing to static storage, to be freed, in the user_change_language_authorized_cb function. This is reachable via the SetLanguage dbus function. This is fixed in versions 0.6.55-0ubuntu12~20.04.5, 0.6.55-0ubuntu13.3, 0.6.55-0ubuntu14.1.
Why it matters now
EPSS 0.0037 31st percentileScored 2026-11-07
Fix Fixed accountsservice (Ubuntu): 0.6.55-0ubuntu12~20.04.5, 0.6.55-0ubuntu13.3, 0.6.55-0ubuntu14.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Ubuntu | accountsservice | 0.6.55-0ubuntu12~20.04 to before 0.6.55-0ubuntu12~20.04.5; 0.6.55-0ubuntu13 to before 0.6.55-0ubuntu13.3; 0.6.55-0ubuntu14 to before 0.6.55-0ubuntu14.1 | 0.6.55-0ubuntu12~20.04.5, 0.6.55-0ubuntu13.3, 0.6.55-0ubuntu14.1 | Patch available | CNA |
- accountsservice VendorUbuntu Affected 0.6.55-0ubuntu12~20.04 to before 0.6.55-0ubuntu12~20.04.5; 0.6.55-0ubuntu13 to before 0.6.55-0ubuntu13.3; 0.6.55-0ubuntu14 to before 0.6.55-0ubuntu14.1 Fixed in 0.6.55-0ubuntu12~20.04.5, 0.6.55-0ubuntu13.3, 0.6.55-0ubuntu14.1 Patch available CNA
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:canonical:accountsservice:*:*:*:*:*:*:*:* | 0.6.55-0ubuntu12\~20.04 to before 0.6.55-0ubuntu12\~20.05; 0.6.55-0ubuntu13 to before 0.6.55-0ubuntu13.3; 0.6.55-0ubuntu14 to before 0.6.55-0ubuntu14.1 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:20.04:*:*:*:lts:*:*:* | 20.04 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:21.04:*:*:*:*:*:*:* | 21.04 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:21.10:*:*:*:*:*:*:* | 21.10 | Vulnerable | Canonical |
- cpe:2.3:a:canonical:accountsservice:*:*:*:*:*:*:*:* Versions 0.6.55-0ubuntu12\~20.04 to before 0.6.55-0ubuntu12\~20.05; 0.6.55-0ubuntu13 to before 0.6.55-0ubuntu13.3; 0.6.55-0ubuntu14 to before 0.6.55-0ubuntu14.1 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:20.04:*:*:*:lts:*:*:* Versions 20.04 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:21.04:*:*:*:*:*:*:* Versions 21.04 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:21.10:*:*:*:*:*:*:* Versions 21.10 Vulnerable ·Canonical
Remediation
- Fix · CNA accountsservice (Ubuntu) Fixed in 0.6.55-0ubuntu12~20.04.5, 0.6.55-0ubuntu13.3, 0.6.55-0ubuntu14.1
Timeline
- 2026-10-02 Threatist record created from CVE-2021-3939
- 2026-10-03 Alias added: GHSA-jxh7-q7rm-43ww
References
More Ubuntu vulnerabilities
- TI-2021-02452 Incorrect authorization in Ubuntu linux kernel KEVCVSS 3.1HIGH 8.8
- TI-2007-05153 Stack-based buffer overflow in the cons_options function in options.c in dhcpd in OpenBSD… CVSS 2.0HIGH 7.2
- TI-2004-01032 Multiple vulnerabilities in the IGMP functionality for Linux kernel 2.4.22 to 2.4.28, and… CVSS 2.0HIGH 10.0
- TI-2004-00896 Multiple buffer overflows in libXML 2.6.12 and 2.6.13 (libxml2), and possibly other… CVSS 2.0HIGH 10.0
- TI-2004-00800 Buffer overflow in the QFILEPATHINFO request handler in Samba 3.0.x through 3.0.7 may… CVSS 2.0HIGH 10.0
- TI-2004-00962 Buffer overflow in the exif_read_data function in PHP before 4.3.10 and PHP 5.x up to… CVSS 2.0HIGH 10.0
Sources
- CVE-2021-3939 · CVE Program
- CVE-2021-3939 · NVD
- FIRST EPSS
- GHSA-jxh7-q7rm-43ww · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences