Heap-based Buffer Overflow in vim/vim
Priority LOW 37CWE-122Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Partial Red Hat: 2 fixed, 2 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and Red Hat. Impact type from CWE-122 and the CVSS impact.
Summary
vim is vulnerable to Heap-based Buffer Overflow
Why it matters now
EPSS 0.01571 75th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Partial vim/vim (vim): 8.2.3625Red Hat: 1 advisoryRed Hat: 2 fixed, 2 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| vim | vim/vim | before 8.2.3625 | 8.2.3625 | Patch available | CNA |
- vim/vim Vendorvim Affected before 8.2.3625 Fixed in 8.2.3625 Patch available CNA
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:vim:vim:*:*:*:*:*:*:*:* | before 8.2.3625 | Vulnerable | vim |
| cpe:2.3:o:fedoraproject:fedora:34:*:*:*:*:*:*:* | 34 | Vulnerable | Fedoraproject |
| cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* | 10.0 | Vulnerable | Debian |
- cpe:2.3:a:vim:vim:*:*:*:*:*:*:*:* Versions before 8.2.3625 Vulnerable ·vim
- cpe:2.3:o:fedoraproject:fedora:34:*:*:*:*:*:*:* Versions 34 Vulnerable ·Fedoraproject
- cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
Remediation
- Fix · CNA vim/vim (vim) Fixed in 8.2.3625
Red Hat 1 advisory
- RHSA-2022:0366 Released 2022-02-01 · Red Hat rating Moderatevim security update
- Red Hat Enterprise Linux AppStream (v. 8) vim-X11-2:8.0.1763-16.el8_5.4, vim-common-2:8.0.1763-16.el8_5.4, vim-enhanced-2:8.0.1763-16.el8_5.4 +1
- Red Hat Enterprise Linux BaseOS (v. 8) vim-2:8.0.1763-16.el8_5.4, vim-minimal-2:8.0.1763-16.el8_5.4
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 6 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 7 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux AppStream (v. 8) | Fixed | RHSA-2022:0366 |
| Red Hat Enterprise Linux BaseOS (v. 8) | Fixed | RHSA-2022:0366 |
Not affected: 2 products
- Red Hat Advanced Cluster Management for Kubernetes 2
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2021-3984
- 2026-10-03 Alias added: GHSA-4jr3-2x33-xqgg
References
More Vim vulnerabilities
- TI-2022-03248 Heap-based Buffer Overflow in vim/vim CVSS 3.1CRITICAL 9.8
- TI-2024-15103 Vim before 9.0.2142 has a stack-based buffer overflow because did_set_langmap in map.c… CVSS 3.1HIGH 7.8
- TI-2023-05093 Use After Free in vim/vim CVSS 3.1HIGH 7.8
- TI-2023-04407 Heap-based Buffer Overflow in vim/vim CVSS 3.1HIGH 7.8
- TI-2023-04379 Heap-based Buffer Overflow in vim/vim CVSS 3.1HIGH 7.8
- TI-2023-04378 Use After Free in vim/vim CVSS 3.1HIGH 7.8
Sources
- CVE-2021-3984 · CVE Program
- CVE-2021-3984 · NVD
- FIRST EPSS
- GHSA-4jr3-2x33-xqgg · GitHub Advisory Database · CC BY 4.0
- CVE-2021-3984 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences