Read the docs
TI-2021-02929 Aliases CVE-2021-4041GHSA-6j58-grhv-2769

Improper input validation in ansible-runner

Priority LOW 34CWE-20Published · Updated

Key facts

Attack vector
Local
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
High · High · High
Fix status
Partial Red Hat: 1 fixed, 7 without a fix

Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat.

Summary

A flaw was found in ansible-runner. An improper escaping of the shell command, while calling the ansible_runner.interface.run_command, can lead to parameters getting executed as host's shell command. A developer could unintentionally write code that gets executed in the host rather than the virtual environment.

Why it matters now

EPSS 0.00332 26th percentileScored 2026-11-07
Fix Partial ansible-runner (PyPI): 2.1.0Red Hat: 1 advisoryRed Hat: 1 fixed, 7 without a fix

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—ansible-runnerFixed in ansible-runner 2.1.0—No fix listedCNA
—ansible-runner (PyPI)before 2.1.02.1.0Patch availableGHSA-6j58-grhv-2769
  • ansible-runner Vendor— Affected Fixed in ansible-runner 2.1.0 Fixed in — No fix listed CNA
  • ansible-runner (PyPI) Vendor— Affected before 2.1.0 Fixed in 2.1.0 Patch available GHSA-6j58-grhv-2769

CPE configurations NVD · 4

CPEVersionsRoleVendor
cpe:2.3:a:redhat:ansible_runner:*:*:*:*:*:*:*:*before 2.1.0VulnerableRed Hat
cpe:2.3:a:redhat:ansible_runner:2.1.0:alpha1:*:*:*:*:*:*2.1.0 alpha1VulnerableRed Hat
cpe:2.3:a:redhat:ansible_runner:2.1.0:alpha2:*:*:*:*:*:*2.1.0 alpha2VulnerableRed Hat
cpe:2.3:a:redhat:ansible_runner:2.1.0:beta1:*:*:*:*:*:*2.1.0 beta1VulnerableRed Hat
  • cpe:2.3:a:redhat:ansible_runner:*:*:*:*:*:*:*:* Versions before 2.1.0 Vulnerable ·Red Hat
  • cpe:2.3:a:redhat:ansible_runner:2.1.0:alpha1:*:*:*:*:*:* Versions 2.1.0 alpha1 Vulnerable ·Red Hat
  • cpe:2.3:a:redhat:ansible_runner:2.1.0:alpha2:*:*:*:*:*:* Versions 2.1.0 alpha2 Vulnerable ·Red Hat
  • cpe:2.3:a:redhat:ansible_runner:2.1.0:beta1:*:*:*:*:*:* Versions 2.1.0 beta1 Vulnerable ·Red Hat

Remediation

  • Fix · GHSA-6j58-grhv-2769 ansible-runner (PyPI) Fixed in 2.1.0 Advisory →

Red Hat 1 advisory

  • RHSA-2022:0108 Released 2022-01-11 · Red Hat rating Moderate
    ansible-runner security and bug fix update
    • Red Hat Ansible Automation Platform 2.0 for RHEL 8 ansible-runner-2.0.3-2.el8ap, python38-ansible-runner-2.0.3-2.el8ap

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
CloudForms Management Engine 5AffectedNo fix planned: Out of support scope
Red Hat Ceph Storage 4AffectedNo fix planned: Out of support scope
Red Hat OpenStack Platform 13 (Queens)AffectedNo fix planned: Out of support scope
Red Hat OpenStack Platform 16.1AffectedNo fix planned: Will not fix
Red Hat OpenStack Platform 16.2AffectedNo fix planned: Will not fix
Red Hat OpenStack Platform 17.0AffectedNo fix planned: Will not fix
Red Hat Satellite 6AffectedNo fix yet
Red Hat Ansible Automation Platform 2.0 for RHEL 8Fixed RHSA-2022:0108
Not affected: 2 products
  • Red Hat OpenShift Container Platform 4
  • Red Hat Virtualization 4

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-4041
  2. 2026-10-03 Alias added: GHSA-6j58-grhv-2769

References

  • TI-2021-02635 Incorrect default permissions in ansible-runner CVSS 3.1MEDIUM 6.6
  • TI-2021-02636 Race condition in ansible-runner CVSS 3.1MEDIUM 6.3

Sources