Memory leak in JSS
Priority LOW 36CWE-401Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and Red Hat. Impact type from CWE-401.
Summary
A flaw was found in JSS, where it did not properly free up all memory. Over time, the wasted memory builds up in the server memory, saturating the server’s RAM. This flaw allows an attacker to force the invocation of an out-of-memory process, causing a denial of service.
Why it matters now
EPSS 0.01736 77th percentileScored 2026-11-07
Fix Fixed Red Hat: 2 advisories
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | JSS | Fixed in v5.2.0-beta1 | — | No fix listed | CNA |
- JSS Vendor— Affected Fixed in v5.2.0-beta1 Fixed in — No fix listed CNA
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:dogtagpki:network_security_services_for_java:*:*:*:*:*:*:*:* | before 4.9.3; 5.0.0 to before 5.1.0 | Vulnerable | Dogtag PKI |
| cpe:2.3:o:redhat:enterprise_linux:8.0:*:*:*:*:*:*:* | 8.0 | Vulnerable | Red Hat |
| cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* | 10.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:* | 11.0 | Vulnerable | Debian |
- cpe:2.3:a:dogtagpki:network_security_services_for_java:*:*:*:*:*:*:*:* Versions before 4.9.3; 5.0.0 to before 5.1.0 Vulnerable ·Dogtag PKI
- cpe:2.3:o:redhat:enterprise_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Red Hat
- cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:* Versions 11.0 Vulnerable ·Debian
Remediation
Red Hat 2 advisories
- RHSA-2024:0774 Released 2024-02-12 · Red Hat rating ModerateRed Hat Certificate System 10.4 for RHEL 8 security and bug fix update
- Red Hat Certificate System 10.4 for RHEL 8 jss-4.9.8-1.module+el8pki+19895+c800dfbd.src::redhat-pki:10, jss-4.9.8-1.module+el8pki+19895+c800dfbd.x86_64::redhat-pki:10, redhat-pki-10.13.9-5.module+el8pki+21062+4ed906e8.x86_64::redhat-pki:10
- RHSA-2022:1851 Released 2022-05-10 · Red Hat rating Moderatepki-core:10.6 security and bug fix update
- Red Hat Enterprise Linux AppStream (v. 8) jss-4.9.3-1.module+el8.6.0+14244+60d461b7.aarch64::pki-core:10.6, jss-4.9.3-1.module+el8.6.0+14244+60d461b7.ppc64le::pki-core:10.6, jss-4.9.3-1.module+el8.6.0+14244+60d461b7.s390x::pki-core:10.6 +27
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Certificate System 10.4 for RHEL 8 | Fixed | RHSA-2024:0774 |
| Red Hat Enterprise Linux AppStream (v. 8) | Fixed | RHSA-2022:1851 |
Not affected: 4 products
- Red Hat Certificate System 10.4 for RHEL 8
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2021-4213
- 2026-10-03 Alias added: GHSA-727r-5fr6-wjfp
References
Patch 3
Sources
- CVE-2021-4213 · CVE Program
- CVE-2021-4213 · NVD
- FIRST EPSS
- GHSA-727r-5fr6-wjfp · GitHub Advisory Database · CC BY 4.0
- CVE-2021-4213 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences