WP Paginate < 2.1.4 - Admin+ Stored Cross-Site Scripting
Priority LOW 24CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The WP-Paginate WordPress plugin before 2.1.4 does not sanitise and escape its preset settings, allowing high privilege users such as admin to perform Cross-Site Scripting attacks even when the unfiltered_html is disallowed
Why it matters now
EPSS 0.0081 57th percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by NVD
Fix Fixed WP-Paginate (Unknown): 2.1.4
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | WP-Paginate | 2.1.4 to before 2.1.4 | 2.1.4 | Patch available | CNA |
- WP-Paginate VendorUnknown Affected 2.1.4 to before 2.1.4 Fixed in 2.1.4 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:maxfoundry:wp-paginate:*:*:*:*:*:wordpress:*:* | before 2.1.4 | Vulnerable | maxfoundry |
- cpe:2.3:a:maxfoundry:wp-paginate:*:*:*:*:*:wordpress:*:* Versions before 2.1.4 Vulnerable ·maxfoundry
Remediation
- Fix · CNA WP-Paginate (Unknown) Fixed in 2.1.4
Timeline
- 2026-10-02 Threatist record created from CVE-2021-4222
- 2026-10-03 Alias added: GHSA-5xxx-9gqj-f6pv
References
More maxfoundry Wp-paginate vulnerabilities
- TI-2022-01899 WP Paginate < 2.1.9 - Admin+ Stored Cross-Site Scripting CVSS 3.1MEDIUM 4.8
Sources
- CVE-2021-4222 · CVE Program
- CVE-2021-4222 · NVD
- FIRST EPSS
- GHSA-5xxx-9gqj-f6pv · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences