phpRedisAdmin cross-site request forgery
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Security bypass, Tampering
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-863 and CWE-352.
Summary
A vulnerability, which was classified as problematic, was found in phpRedisAdmin up to 1.17.3. This affects an unknown part. The manipulation leads to cross-site request forgery. It is possible to initiate the attack remotely. Upgrading to version 1.18.0 is able to address this issue. The name of the patch is b9039adbb264c81333328faa9575ecf8e0d2be94. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-216471.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| unspecified | phpRedisAdmin | 1.14.0; 1.14.1; 1.15.0; 1.16.0; 1.16.1; 1.16.2; 1.17.0; 1.17.1; 1.17.2; 1.17.3 | — | No fix listed | CNA |
- phpRedisAdmin Vendorunspecified Affected 1.14.0; 1.14.1; 1.15.0; 1.16.0; 1.16.1; 1.16.2; 1.17.0; 1.17.1; 1.17.2; 1.17.3 Fixed in — No fix listed CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:phpredisadmin_project:phpredisadmin:*:*:*:*:*:*:*:* | before 1.18.0 | Vulnerable | Phpredisadmin Project |
- cpe:2.3:a:phpredisadmin_project:phpredisadmin:*:*:*:*:*:*:*:* Versions before 1.18.0 Vulnerable ·Phpredisadmin Project
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2021-4268
- 2026-10-03 Alias added: GHSA-r8r8-9qg3-423r
References
More Phpredisadmin Project Phpredisadmin vulnerabilities
- TI-2021-03117 phpRedisAdmin login.inc.php authHttpDigest wrong operator in string comparison CVSS 3.1CRITICAL 9.8
- TI-2020-16512 phpRedisAdmin before 1.13.2 allows XSS via the login.php username parameter. CVSS 3.1MEDIUM 6.1
Sources
- CVE-2021-4268 · CVE Program
- CVE-2021-4268 · NVD
- FIRST EPSS
- GHSA-r8r8-9qg3-423r · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences