OpenMRS openmrs-module-referenceapplication userApp.gsp cross site scripting
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
A vulnerability was found in OpenMRS openmrs-module-referenceapplication up to 2.11.x. It has been rated as problematic. This issue affects some unknown processing of the file omod/src/main/webapp/pages/userApp.gsp. The manipulation leads to cross site scripting. The attack may be initiated remotely. Upgrading to version 2.12.0 is able to address this issue. The name of the patch is 35f81901a4cb925747a9615b8706f5079d2196a1. It is recommended to upgrade the affected component. The identifier VDB-216881 was assigned to this vulnerability.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| OpenMRS | openmrs-module-referenceapplication | 2.0; 2.1; 2.2; 2.3; 2.4; 2.5; 2.6; 2.7; 2.8; 2.9; 2.10; 2.11 | — | No fix listed | CNA |
- openmrs-module-referenceapplication VendorOpenMRS Affected 2.0; 2.1; 2.2; 2.3; 2.4; 2.5; 2.6; 2.7; 2.8; 2.9; 2.10; 2.11 Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2021-4288
- 2026-10-03 Alias added: GHSA-qc24-vqq2-gjjw
References
More OpenMRS Reference Application vulnerabilities
- TI-2018-11851 An XML External Entity (XXE) vulnerability exists in HTML Form Entry 3.7.0, as… CVSS 3.0CRITICAL 9.8
- TI-2021-19148 An SQL Injection vulnerability exists in OpenMRS Reference Application Standalone Edition… CVSS 3.1CRITICAL 9.8
- TI-2021-03147 OpenMRS openmrs-module-referenceapplication User App Page UserAppPageController.java post cross site scripting CVSS 3.1MEDIUM 6.1
Sources
- CVE-2021-4288 · CVE Program
- CVE-2021-4288 · NVD
- FIRST EPSS
- GHSA-qc24-vqq2-gjjw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences