Read the docs
TI-2021-03153 Aliases CVE-2021-4295GHSA-v4wv-v525-p5gq

XML external entity injection in ONC code-validator-api

Priority MEDIUM 43CWE-611Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
High · High · High
Fix status
No fix listed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA.

Summary

A vulnerability classified as problematic was found in ONC code-validator-api up to 1.0.30. This vulnerability affects the function vocabularyValidationConfigurations of the file src/main/java/org/sitenv/vocabularies/configuration/CodeValidatorApiConfiguration.java of the component XML Handler. The manipulation leads to xml external entity reference. Upgrading to version 1.0.31 is able to address this issue. The name of the patch is fbd8ea121755a2d3d116b13f235bc8b61d8449af. It is recommended to upgrade the affected component. VDB-217018 is the identifier assigned to this vulnerability.

Why it matters now

EPSS 0.00778 56th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
ONCcode-validator-api1.0.0; 1.0.1; 1.0.2; 1.0.3; 1.0.4; 1.0.5; 1.0.6; 1.0.7; 1.0.8; 1.0.9; 1.0.10; 1.0.11; 1.0.12; 1.0.13; 1.0.14; 1.0.15; 1.0.16; 1.0.17; 1.0.18; 1.0.19; 1.0.20; 1.0.21; 1.0.22; 1.0.23; 1.0.24; 1.0.25; 1.0.26; 1.0.27; 1.0.28; 1.0.29; 1.0.30—No fix listedCNA
  • code-validator-api VendorONC Affected 1.0.0; 1.0.1; 1.0.2; 1.0.3; 1.0.4; 1.0.5; 1.0.6; 1.0.7; 1.0.8; 1.0.9; 1.0.10; 1.0.11; 1.0.12; 1.0.13; 1.0.14; 1.0.15; 1.0.16; 1.0.17; 1.0.18; 1.0.19; 1.0.20; 1.0.21; 1.0.22; 1.0.23; 1.0.24; 1.0.25; 1.0.26; 1.0.27; 1.0.28; 1.0.29; 1.0.30 Fixed in — No fix listed CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:healthit:code-validator-api:*:*:*:*:*:*:*:*before 1.0.31VulnerableHealthit
  • cpe:2.3:a:healthit:code-validator-api:*:*:*:*:*:*:*:* Versions before 1.0.31 Vulnerable ·Healthit

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-4295
  2. 2026-10-03 Alias added: GHSA-v4wv-v525-p5gq

References

Sources