trampgeek jobe Restapi.php runs_post Privilege Escalation
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
A vulnerability has been found in trampgeek jobe up to 1.6.4 and classified as problematic. This vulnerability affects the function runs_post of the file application/controllers/Restapi.php. The manipulation of the argument sourcefilename leads to an unknown weakness. Upgrading to version 1.6.5 is able to address this issue. The patch is identified as 694da5013dbecc8d30dd83e2a83e78faadf93771. It is recommended to upgrade the affected component. VDB-217174 is the identifier assigned to this vulnerability.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| trampgeek | jobe | 1.6.0; 1.6.1; 1.6.2; 1.6.3; 1.6.4 | — | No fix listed | CNA |
- jobe Vendortrampgeek Affected 1.6.0; 1.6.1; 1.6.2; 1.6.3; 1.6.4 Fixed in — No fix listed CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:jobe_project:jobe:*:*:*:*:*:*:*:* | before 1.6.5 | Vulnerable | Jobe Project |
- cpe:2.3:a:jobe_project:jobe:*:*:*:*:*:*:*:* Versions before 1.6.5 Vulnerable ·Jobe Project
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2021-4297
- 2026-10-03 Alias added: GHSA-7w5v-94w3-9cq7
- 2026-10-12 EPSS moved to the 50th–90th percentile
References
More Jobe Project Jobe vulnerabilities
- TI-2020-18836 trampgeek jobe LanguageTask.php run_in_sandbox command injection CVSS 3.1CRITICAL 9.8
Sources
- CVE-2021-4297 · CVE Program
- CVE-2021-4297 · NVD
- FIRST EPSS
- GHSA-7w5v-94w3-9cq7 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences