cronvel terminal-kit redos
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-1333.
Summary
A vulnerability classified as problematic has been found in cronvel terminal-kit up to 2.1.7. Affected is an unknown function. The manipulation leads to inefficient regular expression complexity. Upgrading to version 2.1.8 is able to address this issue. The name of the patch is a2e446cc3927b559d0281683feb9b821e83b758c. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-217620.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| cronvel | terminal-kit | 2.1.0; 2.1.1; 2.1.2; 2.1.3; 2.1.4; 2.1.5; 2.1.6; 2.1.7 | — | No fix listed | CNA |
| — | terminal-kit (npm) | before 2.1.8 | 2.1.8 | Patch available | GHSA-wxgh-8gmr-3qh3 |
- terminal-kit Vendorcronvel Affected 2.1.0; 2.1.1; 2.1.2; 2.1.3; 2.1.4; 2.1.5; 2.1.6; 2.1.7 Fixed in — No fix listed CNA
- terminal-kit (npm) Vendor— Affected before 2.1.8 Fixed in 2.1.8 Patch available GHSA-wxgh-8gmr-3qh3
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:terminal-kit_project:terminal-kit:*:*:*:*:*:node.js:*:* | before 2.1.8 | Vulnerable | Terminal-kit Project |
- cpe:2.3:a:terminal-kit_project:terminal-kit:*:*:*:*:*:node.js:*:* Versions before 2.1.8 Vulnerable ·Terminal-kit Project
Remediation
- Fix · GHSA-wxgh-8gmr-3qh3 terminal-kit (npm) Fixed in 2.1.8 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-4306
- 2026-10-03 Alias added: GHSA-wxgh-8gmr-3qh3
References
Sources
- CVE-2021-4306 · CVE Program
- CVE-2021-4306 · NVD
- FIRST EPSS
- GHSA-wxgh-8gmr-3qh3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences