NYUCCL psiTurk experiment.py special elements used in a template engine
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-1336.
Summary
A vulnerability has been found in NYUCCL psiTurk up to 3.2.0 and classified as critical. This vulnerability affects unknown code of the file psiturk/experiment.py. The manipulation of the argument mode leads to improper neutralization of special elements used in a template engine. The exploit has been disclosed to the public and may be used. Upgrading to version 3.2.1 is able to address this issue. The name of the patch is 47787e15cecd66f2aa87687bf852ae0194a4335f. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-219676.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| NYUCCL | psiTurk | 3.0; 3.1; 3.2 | — | No fix listed | CNA |
| — | psiTurk (PyPI) | before 3.2.1 | 3.2.1 | Patch available | GHSA-9mq4-9556-6qxq |
- psiTurk VendorNYUCCL Affected 3.0; 3.1; 3.2 Fixed in — No fix listed CNA
- psiTurk (PyPI) Vendor— Affected before 3.2.1 Fixed in 3.2.1 Patch available GHSA-9mq4-9556-6qxq
Remediation
- Fix · GHSA-9mq4-9556-6qxq psiTurk (PyPI) Fixed in 3.2.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-4315
- 2026-10-03 Alias added: GHSA-9mq4-9556-6qxq
References
Patch 2
Sources
- CVE-2021-4315 · CVE Program
- CVE-2021-4315 · NVD
- FIRST EPSS
- GHSA-9mq4-9556-6qxq · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences