Imperative Local Command Injection allows Activity Masking
Priority LOW 34CWE-77Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-77.
Summary
A vulnerability in Imperative framework which allows already-privileged local actors to execute arbitrary shell commands via plugin install/update commands, or maliciously formed environment variables. Impacts Zowe CLI.
Why it matters now
EPSS 0.00255 17th percentileScored 2026-11-07
Fix Fixed Zowe (Open Mainframe Project): 1.28.2, 2.5.0@zowe/imperative (npm): 5.7.1, 4.18.10
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| backstage | Zowe | 1.16.0 to before 1.28.2; 2.0.0 to before 2.5.0 | 1.28.2, 2.5.0 | Patch available | CNA |
| — | @zowe/imperative (npm) | 5.0.0 to before 5.7.1 | 5.7.1 | Patch available | GHSA-6q8m-42qq-64r7 |
| — | @zowe/imperative (npm) | before 4.18.10 | 4.18.10 | Patch available | GHSA-6q8m-42qq-64r7 |
- Zowe Vendorbackstage Affected 1.16.0 to before 1.28.2; 2.0.0 to before 2.5.0 Fixed in 1.28.2, 2.5.0 Patch available CNA
- @zowe/imperative (npm) Vendor— Affected 5.0.0 to before 5.7.1 Fixed in 5.7.1 Patch available GHSA-6q8m-42qq-64r7
- @zowe/imperative (npm) Vendor— Affected before 4.18.10 Fixed in 4.18.10 Patch available GHSA-6q8m-42qq-64r7
Remediation
- Fix · CNA Zowe (Open Mainframe Project) Fixed in 1.28.2, 2.5.0
- Fix · GHSA-6q8m-42qq-64r7 @zowe/imperative (npm) Fixed in 5.7.1 Advisory →
- Fix · GHSA-6q8m-42qq-64r7 @zowe/imperative (npm) Fixed in 4.18.10 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-4326
- 2026-10-03 Alias added: GHSA-6q8m-42qq-64r7
References
Sources
- CVE-2021-4326 · CVE Program
- CVE-2021-4326 · NVD
- FIRST EPSS
- GHSA-6q8m-42qq-64r7 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences