json-logic-js logic.js command injection
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-77.
Summary
A vulnerability, which was classified as critical, has been found in json-logic-js 2.0.0. Affected by this issue is some unknown functionality of the file logic.js. The manipulation leads to command injection. Upgrading to version 2.0.1 is able to address this issue. The patch is identified as c1dd82f5b15d8a553bb7a0cfa841ab8a11a9c227. It is recommended to upgrade the affected component. VDB-222266 is the identifier assigned to this vulnerability.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | json-logic-js | 2.0.0 | — | No fix listed | CNA |
| — | json-logic-js (npm) | before 2.0.1 | 2.0.1 | Patch available | GHSA-67j4-2mh6-8627 |
- json-logic-js Vendor— Affected 2.0.0 Fixed in — No fix listed CNA
- json-logic-js (npm) Vendor— Affected before 2.0.1 Fixed in 2.0.1 Patch available GHSA-67j4-2mh6-8627
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:json-logic-js_project:json-logic-js:2.0.0:*:*:*:*:*:*:* | 2.0.0 | Vulnerable | Json-logic-js Project |
- cpe:2.3:a:json-logic-js_project:json-logic-js:2.0.0:*:*:*:*:*:*:* Versions 2.0.0 Vulnerable ·Json-logic-js Project
Remediation
- Fix · GHSA-67j4-2mh6-8627 json-logic-js (npm) Fixed in 2.0.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-4329
- 2026-10-03 Alias added: GHSA-67j4-2mh6-8627
References
Patch 2
Sources
- CVE-2021-4329 · CVE Program
- CVE-2021-4329 · NVD
- FIRST EPSS
- GHSA-67j4-2mh6-8627 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences