Read the docs
TI-2021-03230 Aliases CVE-2021-4373GHSA-jh73-2gqf-9g2h

Better Search <= 2.5.2 - Cross-Site Request Forgery to Settings Import

Priority MEDIUM 40CWE-288Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Security bypass, Tampering
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-288 and CWE-352.

Summary

The Better Search plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 2.5.2. This makes it possible for unauthenticated attackers to import settings via forged request granted they can trick a site administrator into performing an action such as clicking on a link.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00463 40th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Better Search – Relevant search results for WordPress (ajay): 2.5.3

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
ajayBetter Search – Relevant search results for WordPressbefore 2.5.32.5.3Patch availableCNA
  • Better Search – Relevant search results for WordPress Vendorajay Affected before 2.5.3 Fixed in 2.5.3 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:webberzone:better_search:*:*:*:*:*:wordpress:*:*up to 2.5.2Vulnerableajay
  • cpe:2.3:a:webberzone:better_search:*:*:*:*:*:wordpress:*:* Versions up to 2.5.2 Vulnerable ·ajay

Remediation

  • Fix · CNA Better Search – Relevant search results for WordPress (ajay) Fixed in 2.5.3

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-4373
  2. 2026-10-03 Alias added: GHSA-jh73-2gqf-9g2h

References

  • TI-2024-19315 WordPress Better Search plugin <= 3.3.0 - Stored Cross Site Scripting (XSS) vulnerability CVSS 3.1HIGH 7.1
  • TI-2021-03257 Better Search <= 2.5.2 - Cross-Site Request Forgery Bypass CVSS 3.1MEDIUM 4.3

Sources