Read the docs
TI-2021-03285 Aliases CVE-2021-4428GHSA-gf9p-c4mf-w382

what3words Autosuggest Plugin Setting class-w3w-autosuggest-public.php enqueue_scripts information disclosure

Priority MEDIUM 49CWE-200Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Information disclosure
Confidentiality · integrity · availability
High · None · None
Fix status
No fix listed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-200.

Summary

A vulnerability has been found in what3words Autosuggest Plugin up to 4.0.0 on WordPress and classified as problematic. Affected by this vulnerability is the function enqueue_scripts of the file w3w-autosuggest/public/class-w3w-autosuggest-public.php of the component Setting Handler. The manipulation leads to information disclosure. The attack can be launched remotely. Upgrading to version 4.0.1 is able to address this issue. The patch is named dd59cbac5f86057d6a73b87007c08b8bfa0c32ac. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-234247.

Why it matters now

EPSS 0.15808 96th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
what3wordsAutosuggest Plugin4.0—No fix listedCNA
  • Autosuggest Plugin Vendorwhat3words Affected 4.0 Fixed in — No fix listed CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:what3words:autosuggest:*:*:*:*:*:wordpress:*:*before 4.0.1Vulnerablewhat3words
  • cpe:2.3:a:what3words:autosuggest:*:*:*:*:*:wordpress:*:* Versions before 4.0.1 Vulnerable ·what3words

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-4428
  2. 2026-10-03 Alias added: GHSA-gf9p-c4mf-w382

References

Sources