Sensitive information in log files in ansible
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Partial Red Hat: 7 fixed, 2 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-532.
Summary
A flaw was found in ansible. Credentials, such as secrets, are being disclosed in console log by default and not protected by no_log feature when using those modules. An attacker can take advantage of this information to steal those credentials. The highest threat from this vulnerability is to data confidentiality. Versions before ansible 2.9.18 are affected.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | ansible | ansible 2.9.18 | — | No fix listed | CNA |
| — | ansible (PyPI) | 2.9.0a1 to before 2.9.18rc1 | 2.9.18rc1 | Patch available | GHSA-8f4m-hccc-8qph |
| — | ansible (PyPI) | before 2.8.19rc1 | 2.8.19rc1 | Patch available | GHSA-8f4m-hccc-8qph |
| — | ansible (PyPI) | 2.10.0a1 to before 2.10.7 | 2.10.7 | Patch available | GHSA-8f4m-hccc-8qph |
- ansible Vendor— Affected ansible 2.9.18 Fixed in — No fix listed CNA
- ansible (PyPI) Vendor— Affected 2.9.0a1 to before 2.9.18rc1 Fixed in 2.9.18rc1 Patch available GHSA-8f4m-hccc-8qph
- ansible (PyPI) Vendor— Affected before 2.8.19rc1 Fixed in 2.8.19rc1 Patch available GHSA-8f4m-hccc-8qph
- ansible (PyPI) Vendor— Affected 2.10.0a1 to before 2.10.7 Fixed in 2.10.7 Patch available GHSA-8f4m-hccc-8qph
CPE configurations NVD · 8
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:oracle:virtualization:4.0:*:*:*:*:*:*:* | 4.0 | Vulnerable | Oracle |
| cpe:2.3:a:redhat:ansible:*:*:*:*:*:*:*:* | before 2.8.19; 2.9.0 to before 2.9.18; 2.10.0 to before 2.10.7 | Vulnerable | Red Hat |
| cpe:2.3:a:redhat:ansible_tower:3.0:*:*:*:*:*:*:* | 3.0 | Vulnerable | Red Hat |
| cpe:2.3:a:redhat:cisco_nx-os_collection:*:*:*:*:*:*:*:* | before 1.4.0 | Vulnerable | Red Hat |
| cpe:2.3:a:redhat:community_general_collection:*:*:*:*:*:ansible:*:* | before 1.3.6; 2.0.0 to before 2.0.1 | Vulnerable | Red Hat |
| cpe:2.3:a:redhat:community_network_collection:*:*:*:*:*:ansible:*:* | before 1.3.2; 2.0.0 to before 2.0.1 | Vulnerable | Red Hat |
| cpe:2.3:a:redhat:docker_community_collection:*:*:*:*:*:ansible:*:* | before 1.2.2 | Vulnerable | Red Hat |
| cpe:2.3:a:redhat:google_cloud_platform_ansible_collection:1.0.2:*:*:*:*:*:*:* | 1.0.2 | Vulnerable | Red Hat |
- cpe:2.3:a:oracle:virtualization:4.0:*:*:*:*:*:*:* Versions 4.0 Vulnerable ·Oracle
- cpe:2.3:a:redhat:ansible:*:*:*:*:*:*:*:* Versions before 2.8.19; 2.9.0 to before 2.9.18; 2.10.0 to before 2.10.7 Vulnerable ·Red Hat
- cpe:2.3:a:redhat:ansible_tower:3.0:*:*:*:*:*:*:* Versions 3.0 Vulnerable ·Red Hat
- cpe:2.3:a:redhat:cisco_nx-os_collection:*:*:*:*:*:*:*:* Versions before 1.4.0 Vulnerable ·Red Hat
- cpe:2.3:a:redhat:community_general_collection:*:*:*:*:*:ansible:*:* Versions before 1.3.6; 2.0.0 to before 2.0.1 Vulnerable ·Red Hat
- cpe:2.3:a:redhat:community_network_collection:*:*:*:*:*:ansible:*:* Versions before 1.3.2; 2.0.0 to before 2.0.1 Vulnerable ·Red Hat
- cpe:2.3:a:redhat:docker_community_collection:*:*:*:*:*:ansible:*:* Versions before 1.2.2 Vulnerable ·Red Hat
- cpe:2.3:a:redhat:google_cloud_platform_ansible_collection:1.0.2:*:*:*:*:*:*:* Versions 1.0.2 Vulnerable ·Red Hat
Remediation
- Fix · GHSA-8f4m-hccc-8qph ansible (PyPI) Fixed in 2.9.18rc1 Advisory →
- Fix · GHSA-8f4m-hccc-8qph ansible (PyPI) Fixed in 2.8.19rc1 Advisory →
- Fix · GHSA-8f4m-hccc-8qph ansible (PyPI) Fixed in 2.10.7 Advisory →
Red Hat 4 advisories
- RHSA-2021:2180 Released 2021-06-01 · Red Hat rating ModerateRHV Engine and Host Common Packages security update [ovirt-4.4.6]
- RHEL-8-RHEV-S-4.4 - Red Hat Virtualization Engine 4.4 ansible-2.9.18-1.el8ae
- Red Hat Virtualization 4 Management Agent for RHEL 7 Hosts ansible-2.9.18-1.el8ae
- RHSA-2021:1079 Released 2021-04-09 · Red Hat rating ModerateRed Hat Ansible Automation Platform Operator 1.2 security update
- Red Hat Ansible Automation Platform 1.2 for RHEL 7 ansible-automation-platform/platform-resource-operator-bundle, ansible-automation-platform/platform-resource-rhel7-operator, ansible-automation-platform/platform-resource-runner-rhel7
- RHSA-2021:0663 Released 2021-02-24 · Red Hat rating ModerateAnsible security and bug fix update (2.9.18)
- Red Hat Ansible Engine 2 for RHEL 7 ansible-2.9.18-1.el7ae, ansible-test-2.9.18-1.el7ae
- Red Hat Ansible Engine 2 for RHEL 8 ansible-2.9.18-1.el8ae, ansible-test-2.9.18-1.el8ae
Show 1 more Red Hat advisories
- RHSA-2021:0664 Released 2021-02-24 · Red Hat rating ModerateAnsible security and bug fix update (2.9.18)
- Red Hat Ansible Engine 2.9 for RHEL 7 Server ansible-2.9.18-1.el7ae, ansible-test-2.9.18-1.el7ae
- Red Hat Ansible Engine 2.9 for RHEL 8 ansible-2.9.18-1.el8ae, ansible-test-2.9.18-1.el8ae
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Ansible Tower 3 | Affected | No fix planned: Out of support scope |
| Red Hat Storage 3 | Affected | No fix planned: Will not fix |
| RHEL-8-RHEV-S-4.4 - Red Hat Virtualization Engine 4.4 | Fixed | RHSA-2021:2180 |
| Red Hat Ansible Automation Platform 1.2 for RHEL 7 | Fixed | RHSA-2021:1079 |
| Red Hat Ansible Engine 2 for RHEL 7 | Fixed | RHSA-2021:0663 |
| Red Hat Ansible Engine 2 for RHEL 8 | Fixed | RHSA-2021:0663 |
| Red Hat Ansible Engine 2.9 for RHEL 7 Server | Fixed | RHSA-2021:0664 |
| Red Hat Ansible Engine 2.9 for RHEL 8 | Fixed | RHSA-2021:0664 |
| Red Hat Virtualization 4 Management Agent for RHEL 7 Hosts | Fixed | RHSA-2021:2180 |
Not affected: 3 products
- RHEL-8-RHEV-S-4.4 - Red Hat Virtualization Engine 4.4
- Red Hat Virtualization 4 Management Agent for RHEL 7 Hosts
- Red Hat Virtualization 4 Tools for Red Hat Enterprise Linux 8
Timeline
- 2026-10-02 Threatist record created from CVE-2021-20191
- 2026-10-03 Alias added: GHSA-8f4m-hccc-8qph
References
Advisory 3
Other 8
- [debian-lts-announce] 20231228 [SECURITY] [DLA 3695-1] ansible security update
- https://github.com/ansible/ansible/pull/73488
- https://github.com/ansible/ansible/pull/73489
- https://github.com/ansible/ansible/commit/cc82d986c40328d4ae81298a9d287c95a6326bb0
- https://github.com/ansible/ansible/commit/d74a1b1d1325af2a24848044cf2858987f5a3ecc
- https://access.redhat.com/security/cve/cve-2021-20191
- https://github.com/ansible/ansible
- https://github.com/pypa/advisory-database/tree/main/vulns/ansible/PYSEC-2021-124.yaml
Sources
- CVE-2021-20191 · CVE Program
- CVE-2021-20191 · NVD
- FIRST EPSS
- GHSA-8f4m-hccc-8qph · GitHub Advisory Database · CC BY 4.0
- CVE-2021-20191 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences