Information disclosure in ansible
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Partial Red Hat: 7 fixed, 1 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-200.
Summary
A flaw was found in the Ansible Engine 2.9.18, where sensitive info is not masked by default and is not protected by the no_log feature when using the sub-option feature of the basic.py module. This flaw allows an attacker to obtain sensitive information. The highest threat from this vulnerability is to confidentiality.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | ansible | ansible-engine 2.9.18 | — | No fix listed | CNA |
| — | ansible (PyPI) | 2.10.0a1 to before 2.10.6rc1 | 2.10.6rc1 | Patch available | GHSA-5rrg-rr89-x9mv |
| — | ansible (PyPI) | 2.9.0a1 to before 2.9.18rc1 | 2.9.18rc1 | Patch available | GHSA-5rrg-rr89-x9mv |
| — | ansible (PyPI) | before 2.8.19rc1 | 2.8.19rc1 | Patch available | GHSA-5rrg-rr89-x9mv |
- ansible Vendor— Affected ansible-engine 2.9.18 Fixed in — No fix listed CNA
- ansible (PyPI) Vendor— Affected 2.10.0a1 to before 2.10.6rc1 Fixed in 2.10.6rc1 Patch available GHSA-5rrg-rr89-x9mv
- ansible (PyPI) Vendor— Affected 2.9.0a1 to before 2.9.18rc1 Fixed in 2.9.18rc1 Patch available GHSA-5rrg-rr89-x9mv
- ansible (PyPI) Vendor— Affected before 2.8.19rc1 Fixed in 2.8.19rc1 Patch available GHSA-5rrg-rr89-x9mv
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:redhat:ansible_engine:2.9.18:*:*:*:*:*:*:* | 2.9.18 | Vulnerable | Red Hat |
| cpe:2.3:a:redhat:ansible_automation_platform:1.2:*:*:*:*:*:*:* | 1.2 | Vulnerable | Red Hat |
| cpe:2.3:a:redhat:ansible_engine:2.0:*:*:*:*:*:*:* | 2.0 | Vulnerable | Red Hat |
| cpe:2.3:a:redhat:ansible_engine:2.9:*:*:*:*:*:*:* | 2.9 | Vulnerable | Red Hat |
| cpe:2.3:a:redhat:ansible_tower:3.0:*:*:*:*:*:*:* | 3.0 | Vulnerable | Red Hat |
| cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* | 10.0 | Vulnerable | Debian |
- cpe:2.3:a:redhat:ansible_engine:2.9.18:*:*:*:*:*:*:* Versions 2.9.18 Vulnerable ·Red Hat
- cpe:2.3:a:redhat:ansible_automation_platform:1.2:*:*:*:*:*:*:* Versions 1.2 Vulnerable ·Red Hat
- cpe:2.3:a:redhat:ansible_engine:2.0:*:*:*:*:*:*:* Versions 2.0 Vulnerable ·Red Hat
- cpe:2.3:a:redhat:ansible_engine:2.9:*:*:*:*:*:*:* Versions 2.9 Vulnerable ·Red Hat
- cpe:2.3:a:redhat:ansible_tower:3.0:*:*:*:*:*:*:* Versions 3.0 Vulnerable ·Red Hat
- cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
Remediation
- Fix · GHSA-5rrg-rr89-x9mv ansible (PyPI) Fixed in 2.10.6rc1 Advisory →
- Fix · GHSA-5rrg-rr89-x9mv ansible (PyPI) Fixed in 2.9.18rc1 Advisory →
- Fix · GHSA-5rrg-rr89-x9mv ansible (PyPI) Fixed in 2.8.19rc1 Advisory →
Red Hat 4 advisories
- RHSA-2021:2180 Released 2021-06-01 · Red Hat rating ModerateRHV Engine and Host Common Packages security update [ovirt-4.4.6]
- RHEL-8-RHEV-S-4.4 - Red Hat Virtualization Engine 4.4 ansible-2.9.18-1.el8ae
- Red Hat Virtualization 4 Management Agent for RHEL 7 Hosts ansible-2.9.18-1.el8ae
- RHSA-2021:1079 Released 2021-04-09 · Red Hat rating ModerateRed Hat Ansible Automation Platform Operator 1.2 security update
- Red Hat Ansible Automation Platform 1.2 for RHEL 7 ansible-automation-platform/platform-resource-operator-bundle, ansible-automation-platform/platform-resource-rhel7-operator, ansible-automation-platform/platform-resource-runner-rhel7
- RHSA-2021:0663 Released 2021-02-24 · Red Hat rating ModerateAnsible security and bug fix update (2.9.18)
- Red Hat Ansible Engine 2 for RHEL 7 ansible-2.9.18-1.el7ae, ansible-test-2.9.18-1.el7ae
- Red Hat Ansible Engine 2 for RHEL 8 ansible-2.9.18-1.el8ae, ansible-test-2.9.18-1.el8ae
Show 1 more Red Hat advisories
- RHSA-2021:0664 Released 2021-02-24 · Red Hat rating ModerateAnsible security and bug fix update (2.9.18)
- Red Hat Ansible Engine 2.9 for RHEL 7 Server ansible-2.9.18-1.el7ae, ansible-test-2.9.18-1.el7ae
- Red Hat Ansible Engine 2.9 for RHEL 8 ansible-2.9.18-1.el8ae, ansible-test-2.9.18-1.el8ae
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Ansible Tower 3 | Affected | No fix planned: Out of support scope |
| RHEL-8-RHEV-S-4.4 - Red Hat Virtualization Engine 4.4 | Fixed | RHSA-2021:2180 |
| Red Hat Ansible Automation Platform 1.2 for RHEL 7 | Fixed | RHSA-2021:1079 |
| Red Hat Ansible Engine 2 for RHEL 7 | Fixed | RHSA-2021:0663 |
| Red Hat Ansible Engine 2 for RHEL 8 | Fixed | RHSA-2021:0663 |
| Red Hat Ansible Engine 2.9 for RHEL 7 Server | Fixed | RHSA-2021:0664 |
| Red Hat Ansible Engine 2.9 for RHEL 8 | Fixed | RHSA-2021:0664 |
| Red Hat Virtualization 4 Management Agent for RHEL 7 Hosts | Fixed | RHSA-2021:2180 |
Not affected: 3 products
- RHEL-8-RHEV-S-4.4 - Red Hat Virtualization Engine 4.4
- Red Hat Virtualization 4 Management Agent for RHEL 7 Hosts
- Red Hat Virtualization 4 Tools for Red Hat Enterprise Linux 8
Timeline
- 2026-10-02 Threatist record created from CVE-2021-20228
- 2026-10-03 Alias added: GHSA-5rrg-rr89-x9mv
References
Advisory 4
Other 8
- https://github.com/ansible/ansible/pull/73492
- https://github.com/ansible/ansible/pull/73493
- https://github.com/ansible/ansible/pull/73494
- https://github.com/ansible/ansible/commit/49ebd509df9de1c1fc1bcee00e79a835dd00662c
- https://github.com/ansible/ansible/commit/e41d1f0a3fd6c466192e7e24accd3d1c6501111b
- https://github.com/ansible/ansible/commit/f8ff395d817c3eddc050f809919c15dfb5796120
- https://github.com/ansible/ansible
- https://github.com/pypa/advisory-database/tree/main/vulns/ansible/PYSEC-2021-1.yaml
Sources
- CVE-2021-20228 · CVE Program
- CVE-2021-20228 · NVD
- FIRST EPSS
- GHSA-5rrg-rr89-x9mv · GitHub Advisory Database · CC BY 4.0
- CVE-2021-20228 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences