Memory corruption in httpd
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and Red Hat. Impact type from CWE-119 and the CVSS impact.
Summary
Missing fixes for CVE-2021-40438 and CVE-2021-26691 in the versions of httpd, as shipped in Red Hat Enterprise Linux 8.5.0, causes a security regression compared to the versions shipped in Red Hat Enterprise Linux 8.4. A user who installs or updates to Red Hat Enterprise Linux 8.5.0 would be vulnerable to the mentioned CVEs, even if they were properly fixed in Red Hat Enterprise Linux 8.4. CVE-2021-20325 was assigned to that Red Hat specific security regression and it does not affect the upstream versions of httpd.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | httpd | httpd 2.4.47, httpd 2.4.49 | — | No fix listed | CNA |
- httpd Vendor— Affected httpd 2.4.47, httpd 2.4.49 Fixed in — No fix listed CNA
Remediation
Red Hat 1 advisory
- RHSA-2021:4537 Released 2021-11-09 · Red Hat rating Importanthttpd:2.4 security update
- Red Hat Enterprise Linux AppStream (v. 8) httpd-2.4.37-43.module+el8.5.0+13064+c4b14997.aarch64::httpd:2.4, httpd-2.4.37-43.module+el8.5.0+13064+c4b14997.ppc64le::httpd:2.4, httpd-2.4.37-43.module+el8.5.0+13064+c4b14997.s390x::httpd:2.4 +38
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux AppStream (v. 8) | Fixed | RHSA-2021:4537 |
Not affected: 5 products
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 9
- Red Hat JBoss Core Services
- Red Hat Software Collections
Timeline
- 2026-10-02 Threatist record created from CVE-2021-20325
- 2026-10-03 Alias added: GHSA-4pm7-9gg5-72pv
References
More Red Hat Enterprise Linux vulnerabilities
- TI-2019-08259 Underflow in PHP-FPM can lead to RCE KEVCVSS 3.1CRITICAL 9.8
- TI-2018-10530 Code injection in [UNKNOWN] RichFaces KEVCVSS 3.1CRITICAL 9.8
- TI-2014-05975 GNU Bash through 4.3 bash43-025 processes trailing strings after certain malformed… KEVCVSS 3.1CRITICAL 9.8
- TI-2014-05157 GNU Bash through 4.3 processes trailing strings after function definitions in the values… KEVCVSS 3.1CRITICAL 9.8
- TI-2025-23530 Sudo before 1.9.17p1 allows local users to obtain root access because /etc/nsswitch.conf… KEVCVSS 3.1CRITICAL 9.3
- TI-2021-17490 mod_proxy SSRF KEVCVSS 3.1CRITICAL 9.0
Sources
- CVE-2021-20325 · CVE Program
- CVE-2021-20325 · NVD
- FIRST EPSS
- GHSA-4pm7-9gg5-72pv · GitHub Advisory Database · CC BY 4.0
- CVE-2021-20325 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences