Cross-site scripting in Wekan
Priority LOW 26CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
Wekan, open source kanban board system, between version 3.12 and 4.11, is vulnerable to multiple stored cross-site scripting. This is named 'Fieldbleed' in the vendor's site.
Why it matters now
EPSS 0.0076 55th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix No fix listed No fixed version in the sources yet
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Wekan Team | Wekan | versions between 3.12 and 4.11 | — | No fix listed | CNA |
- Wekan VendorWekan Team Affected versions between 3.12 and 4.11 Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2021-20654
- 2026-10-03 Alias added: GHSA-p4j3-3c38-6j6r
References
More Wekan vulnerabilities
- TI-2026-01855 WeKan Activity Publication activities.js LinkedBoardActivitiesBleed information disclosure CVSS 4.0MEDIUM 6.9
- TI-2023-13025 A stored cross-site scripting (Stored XSS) vulnerability in file preview in WeKan before… CVSS 3.1MEDIUM 5.4
- TI-2026-20667 WeKan < 8.19 LDAP Authentication Filter Injection CVSS 4.0HIGH 8.7
- TI-2026-23675 Wekan Exposes All Global Webhook Integrations through globalwebhooks Publication CVSS 4.0HIGH 8.7
- TI-2026-23673 Wekan Vulnerable to SSRF through Lack of Validation or Filtering in Attachment URL Loading CVSS 4.0CRITICAL 9.3
- TI-2026-23672 Wekan has Cross-Board IDOR in Custom Fields Update Endpoints CVSS 4.0CRITICAL 9.3
Sources
- CVE-2021-20654 · CVE Program
- CVE-2021-20654 · NVD
- FIRST EPSS
- GHSA-p4j3-3c38-6j6r · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences