Read the docs
TI-2021-04055 Aliases CVE-2021-20840GHSA-6wcx-352r-rcj5

Cross-site scripting in SaasProject Booking Package - Appointment Booking Calendar System

Priority LOW 30CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.

Summary

Cross-site scripting vulnerability in Booking Package - Appointment Booking Calendar System versions prior to 1.5.11 allows a remote attacker to inject an arbitrary script via unspecified vectors.

Why it matters now

EPSS 0.01284 70th percentileScored 2026-11-07
Fix Fixed Booking Package - Appointment Booking Calendar System (Saasproject): 1.5.11

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
SaasProjectBooking Package - Appointment Booking Calendar Systembefore 1.5.111.5.11Patch availableCNA
  • Booking Package - Appointment Booking Calendar System VendorSaasProject Affected before 1.5.11 Fixed in 1.5.11 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:saasproject:booking_package:*:*:*:*:*:wordpress:*:*before 1.5.11VulnerableSaasProject
  • cpe:2.3:a:saasproject:booking_package:*:*:*:*:*:wordpress:*:* Versions before 1.5.11 Vulnerable ·SaasProject

Remediation

  • Fix · CNA Booking Package - Appointment Booking Calendar System (Saasproject) Fixed in 1.5.11

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-20840
  2. 2026-10-03 Alias added: GHSA-6wcx-352r-rcj5

References

  • TI-2022-00623 Booking Package < 1.5.29 - Unauthenticated Sensitive Data Disclosure CVSS 3.1HIGH 7.5
  • TI-2023-20817 WordPress Booking Package Plugin <= 1.6.01 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1HIGH 7.1

Sources