Read the docs
TI-2021-04108 Aliases CVE-2021-21002GHSA-wc86-7c83-q7g5

Denial of Service in Phoenix Contact FL COMSERVER UNI products

Priority LOW 35CWE-772Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Denial of service
Confidentiality · integrity · availability
None · None · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-772.

Summary

In Phoenix Contact FL COMSERVER UNI in versions < 2.40 a invalid Modbus exception response can lead to a temporary denial of service.

Why it matters now

EPSS 0.00961 61st percentileScored 2026-11-07
Fix Fixed FL COMSERVER (Phoenix Contact): 2.40

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
Phoenix ContactFL COMSERVERUNI 232/422/485 (2313452) to before 2.40; UNI 232/422/485-T (2904817) to before 2.402.40Patch availableCNA
  • FL COMSERVER VendorPhoenix Contact Affected UNI 232/422/485 (2313452) to before 2.40; UNI 232/422/485-T (2904817) to before 2.40 Fixed in 2.40 Patch available CNA

CPE configurations NVD · 4

CPEVersionsRoleVendor
cpe:2.3:o:phoenixcontact:fl_comserver_uni_232\/422\/485_firmware:*:*:*:*:*:*:*:*before 2.40VulnerablePhoenixcontact
cpe:2.3:h:phoenixcontact:fl_comserver_uni_232\/422\/485:-:*:*:*:*:*:*:*not specified by NVDRunning onPhoenixcontact
cpe:2.3:o:phoenixcontact:fl_comserver_uni_232\/422\/485-t_firmware:*:*:*:*:*:*:*:*before 2.40VulnerablePhoenixcontact
cpe:2.3:h:phoenixcontact:fl_comserver_uni_232\/422\/485-t:-:*:*:*:*:*:*:*not specified by NVDRunning onPhoenixcontact
  • cpe:2.3:o:phoenixcontact:fl_comserver_uni_232\/422\/485_firmware:*:*:*:*:*:*:*:* Versions before 2.40 Vulnerable ·Phoenixcontact
  • cpe:2.3:h:phoenixcontact:fl_comserver_uni_232\/422\/485:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Phoenixcontact
  • cpe:2.3:o:phoenixcontact:fl_comserver_uni_232\/422\/485-t_firmware:*:*:*:*:*:*:*:* Versions before 2.40 Vulnerable ·Phoenixcontact
  • cpe:2.3:h:phoenixcontact:fl_comserver_uni_232\/422\/485-t:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Phoenixcontact

Remediation

  • Fix · CNA FL COMSERVER (Phoenix Contact) Fixed in 2.40

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-21002
  2. 2026-10-03 Alias added: GHSA-wc86-7c83-q7g5

References

  • TI-2014-07463 Phoenix Contact Software ProConOs and MultiProg Missing Authentication for Critical Function CVSS 2.0CRITICAL 10.0
  • TI-2024-17093 PHOENIX CONTACT: Remote code execution in CHARX Series CVSS 3.1CRITICAL 9.8
  • TI-2022-13692 Insufficient Verification of Data Vulnerability in PHOENIX CONTACT classic line industrial controllers CVSS 3.1CRITICAL 9.8
  • TI-2026-21959 Remote code execution via uploading a malicious IODD file CVSS 3.1CRITICAL 9.8
  • TI-2026-21940 Authentication Bypass in _account_log CVSS 3.1CRITICAL 9.8
  • TI-2023-03334 PHOENIX CONTACT: OS Command Injection in WP 6xxx Web panels CVSS 3.1CRITICAL 10.0
See all 194 →

Sources