Reflected Cross-site Scripting (XSS) on version-compare and page-compare tools
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
ACS Commons version 4.9.2 (and earlier) suffers from a Reflected Cross-site Scripting (XSS) vulnerability in version-compare and page-compare due to invalid JCR characters that are not handled correctly. An attacker could potentially exploit this vulnerability to inject malicious JavaScript content into vulnerable form fields and execute it within the context of the victim's browser. Exploitation of this issue requires user interaction in order to be successful.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Adobe | Experience Manager | up to 4.9.2; up to None | — | No fix listed | CNA |
| — | com.adobe.acs:acs-aem-commons (Maven) | before 4.10.0 | 4.10.0 | Patch available | GHSA-7r83-w6r8-fh6w |
- Experience Manager VendorAdobe Affected up to 4.9.2; up to None Fixed in — No fix listed CNA
- com.adobe.acs:acs-aem-commons (Maven) Vendor— Affected before 4.10.0 Fixed in 4.10.0 Patch available GHSA-7r83-w6r8-fh6w
Remediation
- Fix · GHSA-7r83-w6r8-fh6w com.adobe.acs:acs-aem-commons (Maven) Fixed in 4.10.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-21043
- 2026-10-03 Alias added: GHSA-7r83-w6r8-fh6w
References
Advisory 2
Sources
- CVE-2021-21043 · CVE Program
- CVE-2021-21043 · NVD
- FIRST EPSS
- GHSA-7r83-w6r8-fh6w · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences