Insufficient policy enforcement in File System API in Google Chrome on Windows prior to…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
Insufficient policy enforcement in File System API in Google Chrome on Windows prior to 89.0.4389.72 allowed a remote attacker to bypass filesystem restrictions via a crafted HTML page.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Chrome | before 89.0.4389.72 | 89.0.4389.72 | Patch available | CNA |
- Chrome VendorGoogle Affected before 89.0.4389.72 Fixed in 89.0.4389.72 Patch available CNA
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:google:chrome:*:*:*:*:*:*:*:* | before 89.0.4389.72 | Vulnerable | |
| cpe:2.3:o:microsoft:windows:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Microsoft |
| cpe:2.3:o:fedoraproject:fedora:32:*:*:*:*:*:*:* | 32 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:33:*:*:*:*:*:*:* | 33 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:34:*:*:*:*:*:*:* | 34 | Vulnerable | Fedoraproject |
| cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* | 10.0 | Vulnerable | Debian |
- cpe:2.3:a:google:chrome:*:*:*:*:*:*:*:* Versions before 89.0.4389.72 Vulnerable ·Google
- cpe:2.3:o:microsoft:windows:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Microsoft
- cpe:2.3:o:fedoraproject:fedora:32:*:*:*:*:*:*:* Versions 32 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:33:*:*:*:*:*:*:* Versions 33 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:34:*:*:*:*:*:*:* Versions 34 Vulnerable ·Fedoraproject
- cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
Remediation
- Fix · CNA Chrome (Google) Fixed in 89.0.4389.72
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Advisory ·
Google Chrome — FEDORA-2021-4740239e28
32 records Highest priority Priority CRITICAL 1 CRITICAL, 13 MEDIUM, 18 LOW
Other records, highest priority first
- TI-2021-04269 Race condition in Google ChromePriority CRITICAL 97
- TI-2021-04280 Incorrect permission assignment in Google ChromePriority MEDIUM 46
- TI-2021-04263 Out-of-bounds write in Google ChromePriority MEDIUM 42
- Advisory ·
Google Chrome — FEDORA-2021-78547312f2
32 records Highest priority Priority CRITICAL 1 CRITICAL, 13 MEDIUM, 18 LOW
Other records, highest priority first
- TI-2021-04269 Race condition in Google ChromePriority CRITICAL 97
- TI-2021-04280 Incorrect permission assignment in Google ChromePriority MEDIUM 46
- TI-2021-04263 Out-of-bounds write in Google ChromePriority MEDIUM 42
Show 1 more group
- Advisory ·
Google Chrome — DSA-4886
31 records Highest priority Priority CRITICAL 1 CRITICAL, 13 MEDIUM, 17 LOW
Other records, highest priority first
- TI-2021-04269 Race condition in Google ChromePriority CRITICAL 97
- TI-2021-04280 Incorrect permission assignment in Google ChromePriority MEDIUM 46
- TI-2021-04263 Out-of-bounds write in Google ChromePriority MEDIUM 42
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2021-21172
- 2026-10-03 Alias added: GHSA-mc2v-pp94-p8j7
References
More Google Chrome vulnerabilities
- TI-2025-09686 Type confusion in Google Chrome KEVCVSS 3.1CRITICAL 9.8
- TI-2024-07390 Type confusion in Google Chrome KEVCVSS 3.1CRITICAL 9.6
- TI-2024-04898 Type confusion in Google Chrome KEVCVSS 3.1CRITICAL 9.6
- TI-2024-04600 Type confusion in Google Chrome KEVCVSS 3.1CRITICAL 9.6
- TI-2024-04346 Use after free in Google Chrome KEVCVSS 3.1CRITICAL 9.6
- TI-2023-05824 Integer overflow in Google Chrome KEVCVSS 3.1CRITICAL 9.6
Sources
- CVE-2021-21172 · CVE Program
- CVE-2021-21172 · NVD
- FIRST EPSS
- GHSA-mc2v-pp94-p8j7 · GitHub Advisory Database · CC BY 4.0
- CVE-2021-21172 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences