Open default xmlsec1 key-type preference
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Partial Red Hat: 4 without a fix
Attack profile from CVSS 3.1 · CNA. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-347.
Summary
PySAML2 is a pure python implementation of SAML Version 2 Standard. PySAML2 before 6.5.0 has an improper verification of cryptographic signature vulnerability. Users of pysaml2 that use the default CryptoBackendXmlSec1 backend and need to verify signed SAML documents are impacted. PySAML2 does not ensure that a signed SAML document is correctly signed. The default CryptoBackendXmlSec1 backend is using the xmlsec1 binary to verify the signature of signed SAML documents, but by default xmlsec1 accepts any type of key found within the given document. xmlsec1 needs to be configured explicitly to only use only _x509 certificates_ for the verification process of the SAML document signature. This is fixed in PySAML2 6.5.0.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| IdentityPython | pysaml2 | before 6.5.0 | 6.5.0 | Patch available | CNA |
| — | pysaml2 (PyPI) | before 6.5.0 | 6.5.0 | Patch available | GHSA-5p3x-r448-pc62 |
- pysaml2 VendorIdentityPython Affected before 6.5.0 Fixed in 6.5.0 Patch available CNA
- pysaml2 (PyPI) Vendor— Affected before 6.5.0 Fixed in 6.5.0 Patch available GHSA-5p3x-r448-pc62
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:pysaml2_project:pysaml2:*:*:*:*:*:*:*:* | before 6.5.0 | Vulnerable | Pysaml2 Project |
| cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Debian |
- cpe:2.3:a:pysaml2_project:pysaml2:*:*:*:*:*:*:*:* Versions before 6.5.0 Vulnerable ·Pysaml2 Project
- cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
Remediation
- Fix · CNA pysaml2 (IdentityPython) Fixed in 6.5.0
- Fix · GHSA-5p3x-r448-pc62 pysaml2 (PyPI) Fixed in 6.5.0 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat OpenStack Platform 10 (Newton) | Affected | No fix planned: Out of support scope |
| Red Hat OpenStack Platform 13 (Queens) | Affected | No fix planned: Out of support scope |
| Red Hat OpenStack Platform 16.1 | Affected | No fix planned: Will not fix |
| Red Hat OpenStack Platform 16.2 | Affected | No fix planned: Will not fix |
Timeline
- 2026-10-02 Threatist record created from CVE-2021-21239
- 2026-10-03 Alias added: GHSA-5p3x-r448-pc62
References
Advisory 5
- https://github.com/IdentityPython/pysaml2/security/advisories/GHSA-5p3x-r448-pc62
- https://pypi.org/project/pysaml2
- https://github.com/IdentityPython/pysaml2/releases/tag/v6.5.0
- [debian-lts-announce] 20210226 [SECURITY] [DLA 2577-1] python-pysaml2 security update
- https://nvd.nist.gov/vuln/detail/CVE-2021-21239
Sources
- CVE-2021-21239 · CVE Program
- CVE-2021-21239 · NVD
- FIRST EPSS
- GHSA-5p3x-r448-pc62 · GitHub Advisory Database · CC BY 4.0
- CVE-2021-21239 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences