Read the docs
TI-2021-04377 Aliases CVE-2021-21277GHSA-j6px-jwvv-vpwq

Angular Expressions - Remote Code Execution

Priority MEDIUM 43CWE-74Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-94.

Summary

angular-expressions is "angular's nicest part extracted as a standalone module for the browser and node". In angular-expressions before version 1.1.2 there is a vulnerability which allows Remote Code Execution if you call "expressions.compile(userControlledInput)" where "userControlledInput" is text that comes from user input. The security of the package could be bypassed by using a more complex payload, using a ".constructor.constructor" technique. In terms of impact: If running angular-expressions in the browser, an attacker could run any browser script when the application code calls expressions.compile(userControlledInput). If running angular-expressions on the server, an attacker could run any Javascript expression, thus gaining Remote Code Execution. This is fixed in version 1.1.2 of angular-expressions A temporary workaround might be either to disable user-controlled input that will be fed into angular-expressions in your application or allow only following characters in the userControlledInput.

Why it matters now

EPSS 0.02848 86th percentileScored 2026-11-07
Fix Fixed angular-expressions (peerigon): 1.1.2angular-expressions (npm): 1.1.2

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
peerigonangular-expressionsbefore 1.1.21.1.2Patch availableCNA
—angular-expressions (npm)before 1.1.21.1.2Patch availableGHSA-j6px-jwvv-vpwq
  • angular-expressions Vendorpeerigon Affected before 1.1.2 Fixed in 1.1.2 Patch available CNA
  • angular-expressions (npm) Vendor— Affected before 1.1.2 Fixed in 1.1.2 Patch available GHSA-j6px-jwvv-vpwq

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:peerigon:angular-expressions:*:*:*:*:*:node.js:*:*before 1.1.2Vulnerablepeerigon
  • cpe:2.3:a:peerigon:angular-expressions:*:*:*:*:*:node.js:*:* Versions before 1.1.2 Vulnerable ·peerigon

Remediation

  • Fix · CNA angular-expressions (peerigon) Fixed in 1.1.2
  • Fix · GHSA-j6px-jwvv-vpwq angular-expressions (npm) Fixed in 1.1.2 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-21277
  2. 2026-10-03 Alias added: GHSA-j6px-jwvv-vpwq

References

  • TI-2026-32543 Angular Expressions - Remote Code Execution using filters CVSS 4.0CRITICAL 9.3
  • TI-2020-04275 Remote Code Execution in Angular Expressions CVSS 3.1HIGH 8.8

Sources